hostapd-0.6.9 configed into WEP configuration but auth in opensystem way

Jouni Malinen j
Wed Jun 17 10:43:15 PDT 2009

On Thu, Jun 18, 2009 at 12:55:34AM +1200, aaaaa aaaaa wrote:

> I tried to config the hostapd.conf into WEP-40 mode.
> But when I run hostapd and connect to it, the server alway run in a open system auth mode :(

And that would be because you configured hostapd to use open system with
WEP.. Based on your comment here, it sounds like you would like to use
shared key authentication instead(?).

> I feel puzzled. Does hostapd-0.6.9 supports WEP encrypt mode? Or I should use 0.5.8 version?

Both 0.6.9 and 0.5.8 support WEP and WEP can be used with both open
system and shared key authentication.

> ===hostapd.conf===

> auth_algs=1

1 = open system
2 = shared key
3 = allow either

> ieee8021x=1
> eapol_version=2
> eap_message=hello
> wep_key_len_broadcast=5
> wep_key_len_unicast=5
> wep_rekey_period=300
> eapol_key_index_workaround=0

However, this makes me think that maybe you do not want to use shared
key authentication after all and are thinking of using IEEE 802.1X
instead(?). If that is the case, please note that it will use open
system authentication as far as IEEE 802.11 authentication is concerned
and that will only be followed by EAPOL authentication.

> eap_server=1

If you are planning on using the internal EAP server, you will also need
to configure it properly (eap_user_file, certificate/private key, etc.)
as shown in the example hostapd.conf.

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list