hostapd fails to set up vlans properly

Blaž Bačnik bacnik
Sun Jul 5 12:31:20 PDT 2009

Instead of packets arriving on vlan interface (eg. wlan0.1), they
arrive on the main interface (wlan0).
I noticed that vlan interface is created but sometimes isn't even up.
Manually bringing it up does not help.
If I bring up the vlan interface before wireless client connects, I
see EAP packets passing through it for a
limited time (namely, during auth) but it would seem like something
messes it up afterwards.
There are no vlans listed for wireless interface in vconfig either but
this might be due to design?

I have also tried full dynamic vlans and hostapd sets up bridges and
vlans for the other interface properly
(they're listed in vconfig and added to the appropriate bridge).

I'm running hostapd-0.6.9 with nl80211 driver and a pretty recent
compat-wireless (b43) on a MIPS board.
I've tried git as well.

Any ideas would be most appreciated.

Regards, B

More information about the Hostap mailing list