hostapd + madwifi Failed to get WPA/RSN IE

Michael Everett meverett
Tue Jan 27 11:15:52 PST 2009

Attempting to connect from a wireless client to an Access Point running
hostapd and madwifi with WPA2 with Pre-shared key (PSK) or with EAP.
Hostapd (with -dd) emits following message on the access point: (see
below for versions of stuff, had this working with earlier Linux
kernel).  Also, the ath0 interface is included in a bridge br0 on the
access point.
hostapd -dd /etc/hostapd/hostapd.conf.wpa_psk
Configuration file: /etc/hostapd/hostapd.conf.wpa_psk
Configure bridge br0 for EAPOL traffic.
madwifi_set_iface_flags: dev_up=0
br0: port 2(ath0) entering disabled state
madwifi_set_privacy: enabled=0
BSS count 1, BSSID mask ff:ff:ff:ff:ff:ff (0 bits)
SIOCGIWRANGE: WE(compiled)=22 WE(source)=13 enc_capa=0xf
ath0: IEEE 802.11 Fetching hardware channel/rate support not supported.
Flushing old station entries
madwifi_sta_deauth: addr=ff:ff:ff:ff:ff:ff reason_code=3
ioctl[IEEE80211_IOCTL_SETMLME]: Argument list too long
madwifi_sta_deauth: Failed to deauth STA (addr ff:ff:ff:ff:ff:ff reason
Could not connect to kernel driver.
Deauthenticate all stations
madwifi_set_privacy: enabled=0
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=0
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=1
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=2
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=3
Using interface ath0 with hwaddr 00:80:48:55:96:aa and ssid 'TEST_SSID'
madwifi_set_ieee8021x: enabled=1
madwifi_configure_wpa: group key cipher=3
madwifi_configure_wpa: pairwise key ciphers=0x8
madwifi_configure_wpa: key management algorithms=0x2
madwifi_configure_wpa: rsn capabilities=0x0
madwifi_configure_wpa: enable WPA=0x3
WPA: group state machine entering state GTK_INIT (VLAN-ID 0)
GMK - hexdump(len=32): [REMOVED]
GTK - hexdump(len=16): [REMOVED]
WPA: group state machine entering state SETKEYSDONE (VLAN-ID 0)
madwifi_set_key: alg=CCMP addr=00:00:00:00:00:00 key_idx=1
madwifi_set_privacy: enabled=1
madwifi_set_iface_flags: dev_up=1
ath0: Setup of interface done.
l2_packet_receive - recvfrom: Network is down
Wireless event: cmd=0x8b1a len=21
Wireless event: cmd=0x8c03 len=20
------------------------here's the error---------------------------
ath0: STA 00:21:29:ea:c9:54 IEEE 802.11: associated
  New STA
ioctl[unknown???]: Invalid argument
madwifi_process_wpa_ie: Failed to get WPA/RSN IE
Failed to get WPA/RSN information element.
Wireless event: cmd=0x8c03 len=20
ath0: STA 00:18:39:11:8a:41 IEEE 802.11: associated
  New STA
ioctl[unknown???]: Invalid argument
madwifi_process_wpa_ie: Failed to get WPA/RSN IE
Failed to get WPA/RSN information element.
Running Debian Linux on ARM PXA-270.  Originally had this working on
kernel v2.6.16.60.  Kernel config was from ARM board manufacturer.
Wireless is Atheros AR5212 on mini-PCI  
Madwifi-ng version 0.9.4 (svn v3354)
Original working config: -- worked for both PSK and EAP modes.
Debian kernel v2.6.16.60
Wireless extensions was v19
hostapd v0.5.5
madwifi 0.9.4
Had to update kernel to v2.6.24.7 for additional hardware feature and
now I get above error when client attempts to connect
Debian kernel v2.6.24.7
Wireless extensions v22
hostapd v0.5.11 (rebuilt on new kernel)
madwifi 0.9.4 (rebuilt on new kernel)
(also previously tested with hostapd v0.5.5 before trying 0.5.11, but
same result.)
wireless client in both cases is a Linksys USB WUSB54GSC running on a
WinXP sp2 box.
error is comming from ioctl call in driver_madwifi::set80211priv for
This is defined in madwifi code /net80211/ieee80211_ioctl.h as
SIOCDEVPRIVATE+4.  SIOCDEVPRIVATE is defined in linux/include/sockios.h
as 0x89F0.  I was able to confirm that when the above error occurs the
op-code is 0x89F4.  
At this point, I'm stumped.  Is the linux kernel missing something
hostapd or madwifi are expecting?  Wireless extensions problem?  Any
help would be appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Hostap mailing list