wpa_supplicant segmentation fault

Cristian NAVALICI cristian.navalici
Tue Feb 24 06:42:52 PST 2009


I'm struggling to get up an wireless card (EDIMAX PCI adapter based on
Ralink RT2561/RT61 802.11g chipset). I managed to install the card
drivers, everything seems to be ok.

# iwconfig
lo        no wireless extensions.

wlan0     RT61 Wireless  ESSID:"DiamondAccess"  Nickname:"localhost.localdomain"
          Mode:Managed  Frequency:2.412 GHz  Bit Rate=54 Mb/s   
          RTS thr:off   Fragment thr:off
          Encryption key:3132-3334-4A4B-4734-6F70-654E-4D
          Link Quality=0/100  Signal level:-121 dBm  Noise level:-111 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I tried then to use wpa_supplicant for WAP encryption with my wireless
router, but when I tried to start up wpa_supplicant I got a nasty
segmentation fault error.

wpa_supplicant v0.6.8
wpa_supplicant -Dralink -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf -dd
Scan results: 0
Cached scan results are empty - not posting
Selecting BSS from priority group 1
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.
Setting scan request: 0 sec 0 usec
Starting AP scan (broadcast SSID)
EAPOL: disable timer tick
Scan timeout - try to get results
Segmentation fault

More debugging info:

(gdb) run /usr/local/sbin/wpa_supplicant -Dralink -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf 
Starting program: /usr/local/sbin/wpa_supplicant /usr/local/sbin/wpa_supplicant -Dralink -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
ioctl[SIOCGIWAP]: Transport endpoint is not connected
ioctl[SIOCGIWAP]: Transport endpoint is not connected
ioctl[SIOCGIWAP]: Transport endpoint is not connected
ioctl[SIOCGIWAP]: Transport endpoint is not connected

Program received signal SIGSEGV, Segmentation fault.
0x00002b24e2be647b in memcpy () from /lib64/libc.so.6

Libraries involved:

ldd /usr/local/sbin/wpa_supplicant
        libssl.so.6 => /lib64/libssl.so.6 (0x00002af1f99a4000)
        libcrypto.so.6 => /lib64/libcrypto.so.6 (0x00002af1f9bed000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002af1f9f35000)
        libc.so.6 => /lib64/libc.so.6 (0x00002af1fa13a000)
        libgssapi_krb5.so.2 => /usr/lib64/libgssapi_krb5.so.2 (0x00002af1fa48e000)
        libkrb5.so.3 => /usr/lib64/libkrb5.so.3 (0x00002af1fa6bc000)
        libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00000036ab600000)
        libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3 (0x00002af1fa950000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00000036a1c00000)
        /lib64/ld-linux-x86-64.so.2 (0x00002af1f9788000)
        libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0 (0x00002af1fab76000)
        libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00000036ac600000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00002af1fad7e000)
        libselinux.so.1 => /lib64/libselinux.so.1 (0x00000036a0400000)
        libsepol.so.1 => /lib64/libsepol.so.1 (0x00000036a0800000)

This wpa_supplicant is built from the sources, but I tried either with
I run Centos 5.2 64bit version.

As a curiosity, on the same computer, but with Centos 5 32bit version,
this seems to work without any problem. So I guess it's related to 64bit

Anyone can help?
Thanks in advance.


More information about the Hostap mailing list