WPA-PSK on Thinkpad T40

Stephen Bosch posting
Wed Dec 16 01:04:02 PST 2009

Okay, well, I tried it frontwards, backwards and sideways, and nothing
is working. Comments below.

On Wed, Dec 16, 2009 at 8:57 AM, Stephen Bosch <posting at vodacomm.ca> wrote:
> Hi, Brian, thanks for the reply.
> My comments below:
> On Wed, Dec 16, 2009 at 4:33 AM, Brian Bender <d6p0d8f02 at sneakemail.com> wrote:
>> On Tue, Dec 15, 2009 at 7:35 PM, Stephen Bosch posting-at-vodacomm.ca
>> |hostaplist/Allow to me| <ap7zwsp4mt at sneakemail.com> wrote:
>>> The problem is that my psk is 26 characters, and this works with other
>>> operating systems, so I don't understand why wpa_supplicant should be
>>> rejecting it.
>> Your network's passphrase is a string that just happens to look like a
>> hex number. It's still just a string to the algorithm that uses it --
>> are you sure you entered it correctly? It's a _case-sensitive_ string,
>> for one thing...
> Well, I entered it, exactly as I have it on record, in Windows, where
> it works, or you wouldn't be reading this message :)
> I have tried it, in quotation marks, in exactly that form.
> wpa_supplicant accepts it, but the handshake fails. Perhaps the
> problem is not in the PSK, but the output doesn't provide an obvious
> (at least, to me) clue. At any rate, it fails with the classic error
> message:
> "WPA: 4-Way Handshake failed - pre-shared key may be incorrect"
> The form in my example is with lowercase letters, which was an
> experiment to see if that would make any difference. I have not tested
> it with quotation marks yet.

I have now tried it:

psk="hex_lowercase" (accepted, but handshake fails)
psk="hex_uppercase" (accepted, but handshake fails)
psk=hex_lowercase (fails to parse)
psk=hex_uppercase (fails to parse)
(accepted, but handshake fails)
(accepted, but handshake fails)

The verbose debug output doesn't clearly (to me, at least) why it is
failing, apart from the already mentioned error message.

All other things being equal, one would intuitively suspect an
incorrect passphrase, but I have configured the wireless network here
twice, and in both cases I used it exactly as I have typed it in the
examples. I have double and triple-checked them. I would be prepared
to try the passphrase again using the working OS, just to make
absolutely sure... but if it does turn out to be incorrect then I'm
going to lose all my connectivity, so I'd want to wait until my
roommate is back.

Just FYI, when I do an iwlist eth1 scan and look at the details for
the WLAN in question, it says it is a WPA Version 1, pairwise TKIP and
TKIP cipher network. Which is how I have it configured in

I'm stumped. What am I missing here?


More information about the Hostap mailing list