"Hardware does not support configured mode" on AR9285 / ath9k

Tom Jaster futur3.tom
Sun Dec 13 10:23:38 PST 2009

i think i have the same chip (shows AR928X in sysinfo),
i see that you're using Karmic Koala, please try the mainline Kernel
(2.6.32) with newest _self compiled_ hostapd version (don't forget the
compile flags).

I had the same Problems with Karmic and hostapd from the repository, even if
you get it to work you'll likely have problems with reconnecting to the
Using my setup _should_ solve it (worked for some guys)

If you are still having problems, please post your log and your config

- Tom

2009/12/13 Peter Michelis <peter.michelis at googlemail.com>

> Hello!
> I am trying to build an access point with an Atheros AR9285 Card. The
> lspci-id is 168c:002b (rev 01).
> I am using an Ubuntu Distribution with the shipped kernel
> 2.6.31-16-generic-pae and hostapd 0.6.9.
> I configured the hostapd to use the nl80211 driver.  When I start
> hostapd on the wlan0 interface with "hostapd -d hostapd.conf" i get:
> ------
> Configuration file: hostapd.conf
> ctrl_interface_group=0
> Opening raw packet socket for ifindex -1215651852
> BSS count 1, BSSID mask ff:ff:ff:ff:ff:ff (0 bits)
> SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
> nl80211: Added 802.11b mode based on 802.11g information
> Hardware does not support configured mode
> wlan0: IEEE 802.11 Hardware does not support configured mode (2)
> Could not select hw_mode and channel. (-1)
> wlan0: Unable to setup interface.
> ------
> I also tried the latest hostapd 0.7 with the same result.
> A bit strange after running hostapd: iwconfig gives me:
> ------
> wlan0     IEEE 802.11bgn  Mode:Master  Frequency:2.427 GHz  Tx-Power=20 dBm
>           Retry  long limit:7   RTS thr:off   Fragment thr:off
>           Encryption key:off
>           Power Management:off
>           Link Quality:0  Signal level:0  Noise level:0
>           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
> ------
> This means that the wireless device is runnung in Master Mode but not
> with hostapd, right??!
> By the way - wpa_supplicant is running very well with wpa2 on the device.
> Any ideas how I get hostapd running? Thank you very much for your help!
> Bye
> Peter
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20091213/e1f861a5/attachment.htm 

More information about the Hostap mailing list