"Hardware does not support configured mode" on AR9285 / ath9k

Peter Michelis peter.michelis
Sun Dec 13 08:41:27 PST 2009


I am trying to build an access point with an Atheros AR9285 Card. The 
lspci-id is 168c:002b (rev 01).

I am using an Ubuntu Distribution with the shipped kernel 
2.6.31-16-generic-pae and hostapd 0.6.9.

I configured the hostapd to use the nl80211 driver.  When I start 
hostapd on the wlan0 interface with "hostapd -d hostapd.conf" i get:

Configuration file: hostapd.conf
Opening raw packet socket for ifindex -1215651852
BSS count 1, BSSID mask ff:ff:ff:ff:ff:ff (0 bits)
SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
nl80211: Added 802.11b mode based on 802.11g information
Hardware does not support configured mode
wlan0: IEEE 802.11 Hardware does not support configured mode (2)
Could not select hw_mode and channel. (-1)
wlan0: Unable to setup interface.

I also tried the latest hostapd 0.7 with the same result.

A bit strange after running hostapd: iwconfig gives me:

wlan0     IEEE 802.11bgn  Mode:Master  Frequency:2.427 GHz  Tx-Power=20 dBm
           Retry  long limit:7   RTS thr:off   Fragment thr:off
           Encryption key:off
           Power Management:off
           Link Quality:0  Signal level:0  Noise level:0
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:0  Invalid misc:0   Missed beacon:0

This means that the wireless device is runnung in Master Mode but not 
with hostapd, right??!

By the way - wpa_supplicant is running very well with wpa2 on the device.

Any ideas how I get hostapd running? Thank you very much for your help!


More information about the Hostap mailing list