Fwd: F12 + ath9k + hostapd (0.7.0) = problems

jaivuk jaivuk
Tue Dec 1 06:24:31 PST 2009

Hi guys,

I sent below e-mail to Fedora list and I'm sending it to you as well as I'm
not sure if the issue is caused by hostapd or by Fedora 12 latest kernels.

Also please note that I was not able to compile latest trunk version on
Fedora 12 (with F12 kernel)

If you need any additional information let me know.

Thank you,


---------- Forwarded message ----------
From: jaivuk <jaivuk at googlemail.com>
Date: Tue, Dec 1, 2009 at 1:36 PM
Subject: F12 + ath9k + hostapd (0.7.0) = problems
To: "Community assistance, encouragement, and advice for using Fedora." <
fedora-list at redhat.com>

Hello guys,

After the a bit problematic upgrade to F12 I tried to make my wifi AP (WPA2)
work. SoI compiled hostapd trunk version I used without a problem in F11 and
I immediately experienced DHCP problems and wifi clients were disconnected
after about 2-5 minutes after the handshake was established (and did not
reconnect afterwards).

I made an upgrade to the latest F12 kernel and tried again. I also tried
latest developement hostapd version - 0.7.0 but without luck.

As the last resort I managed to install latest F11 kernel to my F12 and
bingo - wifi is stable and DHCP problems dissapeared.

So in summary:
F12 kernel kernel-PAE- and
kernel-PAE- do not work for me with hostapd 0.7.0 or
older trunk version.
F11 kernel kernel-PAE- works fine.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20091201/f44e13e6/attachment.htm 

More information about the Hostap mailing list