rt61 + hostapd: "Failed to create interface mon.wlan0"

xtof.pernod xtof.pernod
Tue Sep 16 11:30:05 PDT 2008

Lee Garrett wrote:
> xtof.pernod wrote:
>> (...)
>> nl80211 driver initialization failed.
>> wlan0: Unable to setup interface.
>> (...)
>> Any idea of what's going on ? 
>> (...)
> Hi there,
> how did you get hostapd to compile against libnl-1.1? As far as I tried, it
> did not compile. 


hostapd-0.6.4 compiles, the git version too, and links against the 
current libnl that I simply downloaded from the official page. What
errors did you get ?

I've had compilation troubles on the libnl git version (some files like
libnl-2.0.pc did not exist, but I'm completely new to git: I may have 
missed smthing), but compilation of hostapd fails (some prototypes do 
not match):

driver_nl80211.c:2002: error: too few arguments to function 
driver_nl80211.c:2002: warning: assignment makes pointer from integer 
without a cast

> Working with latest git version of rt2x00, hostapd and libnl
> at least brought up the interface, 

Promising !..
Is the git version better than the dayly CVS snapshot ?

> though I ran into other problems (see my
> previous post "hostapd git with rt73usb not working")

[in which you said:]

 > I'm trying to run hostapd as AP on an mac80211 wlan stick. I'm using
 > an rt2x00 git kernel,

This might make a difference (?)
I will try that too.

> Kind regards,
> Lee


More information about the Hostap mailing list