wpa-ttls connection problems

samuel samuel.verstraete
Wed Sep 3 12:39:06 PDT 2008

Seems like my setup was right...
it works prefectly on another computer...

so i'm still wondering what could be wrong...
is it SSL that is borked on my machine? wpa_supplicant?
any ideas?

On Tue, Aug 19, 2008 at 8:47 PM, samuel <samuel.verstraete at gmail.com> wrote:
> On Tue, Aug 19, 2008 at 8:43 PM, samuel <samuel.verstraete at gmail.com> wrote:
>> On Tue, Aug 19, 2008 at 8:02 PM, Jouni Malinen <j at w1.fi> wrote:
>>> On Tue, Aug 19, 2008 at 02:51:21PM +0200, samuel wrote:
>>>> My university has a wireless network and they handed out instructions
>>>> to connect to the network for windows and macosx...
>>>> These are the instructions for the osX connection:
>>>> http://helpdesk.ugent.be/ugentnet/UGentWPA_MACOS.pdf
>>>> **I have tried to translate this in what i think should be a correct
>>>> wpa_supplicant config... still it doesn't seem to be able to connect:
>>> Your configuration looks fine to me and seems to match with what is
>>> described in the instructions for OS X.
>>>> **this is the log when i turn on extreme logging:
>>>> http://merlin.ugent.be/log
>>> This seems to show successfully started EAP-TTLS handshake. However, the
>>> authentication server behavior on processing the first EAP-TTLS packet
>>> from the peer is odd. It tries to start EAP-PEAP at that point which is
>>> not allowed change at that point in EAP handshake.. Would you happen to
>>> know which authentication server is used?
>> I have absolutely no idea...  But i guess i could ask them...
>> but i do know that the university network has PEAP access as well...
>> but I was told that one is less stable than TTLS...
>> I do have instructions for NetworkManager in Ubuntu for the PEAP thingy... :
>> http://helpdesk.ugent.be/ugentnet/UGentWPA_ubuntu.pdf
>> i've "translated" those instructions as well... to no avail...
>> network={
>>        ssid="UGentWPA"
>>        scan_ssid=1
>>        key_mgmt=WPA-EAP
>>        eap=PEAP
>>        identity="GEBRUIKER"
>>        password="PASWOORD"
>>        ca_cert="/etc/certs/ct_root.pem"
>>        priority=1
>>        }
>> i get pretty much the same error actually....
> Don't know if i it matters but i'm using the ath9k driver from the
> 2.6.27rc3 kernel
>>> --
>>> Jouni Malinen                                            PGP id EFC895FA
>>> _______________________________________________
>>> HostAP mailing list
>>> HostAP at lists.shmoo.com
>>> http://lists.shmoo.com/mailman/listinfo/hostap

More information about the Hostap mailing list