Hostapd and wpa_supplicant configuration -Failure - Invalid MAC_P - supplicant used different EAP type 47

Jouni Malinen j
Fri Oct 31 06:52:55 PDT 2008

On Wed, Oct 22, 2008 at 04:09:06PM +0200, jackbaker wrote:

> Hostapd is on 0.5.x

Which exact version of hostapd are you using?
Which version of wpa_supplicant are you using?

> I want to use hostapd and wpa_supplicant to sercure the access to a
> Network. I want to use WPA-EAP with EAP-PSK. I have installed hostapd in
> the Access Point and wa_supplicant in the client laptop. 
> I have got a message "INVALID MAC_P" then a failure on "AP Get decision". At Last "Authenfication failed EAP type 0 (unknown)" and "Supplicant used different EAP type 47"

I ran a quick test with the current 0.5.x development branch versions of
hostapd and wpa_supplicant and the configuration files you used for
setting the EAP-PSK parameters worked fine.. Invalid MAC_P sounds like a
mismatch in the shared key used for EAP-PSK.

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list