Cannot allocate memory problem

Tomasz Pieruszka tomasz.pieruszka
Wed Oct 29 15:32:41 PDT 2008


I'm having problems with hostap module.

I'm using Slackware 12.1 upgraded to the "-current" version and 2.6.24
kernel version.
The hostap module is blacklisted by default. When I launch my computer
and execute:
modprobe hostap_pci
everything works just fine.

Problems occur when I uncomment hostap_pci module in
/etc/modules.d/blacklist and reboot my computer.
The output of the dmesg is:
root at slackap:~# dmesg |grep wifi
hostap_pci: Registered netdevice wifi0
wifi0: Original COR value: 0x0
wifi0: NIC: id=0x8013 v1.0.0
wifi0: PRI: id=0x15 v1.1.1
wifi0: STA: id=0x1f v1.8.4
wifi0: Intersil Prism2.5 PCI: mem=0xec010000, irq=19
wifi0: registered netdevice wlan0
udev: renamed network interface wifi0 to eth0ap

And then:

root at slackap:~# iwconfig eth0
eth0      IEEE 802.11b  ESSID:"test"  Nickname:""
          Mode:Master  Access Point: Not-Associated   Bit Rate:11 Mb/s
          Retry short limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
root at slackap:~# hostapd -ddd /HostAPd/hostapd-WEP-prism.conf
Configuration file: /HostAPd/hostapd-WEP-prism.conf
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Cannot allocate memory
Could not enable hostapd mode for interface eth0
hostap driver initialization failed.
eth0: Unable to setup interface.
Flushing old station entries
Deauthenticate all stations
rmdir[ctrl_interface]: No such file or directory

What is even more strange, that when I remove the module, and insert
it again, everything works again:

root at slackap:~# ifconfig eth0 down
root at slackap:~# rmmod hostap_pci
root at slackap:~# modprobe hostap_pci
root at slackap:~# ifconfig eth0 up
root at slackap:~# hostapd -ddd /HostAPd/hostapd-WEP-prism.conf
Configuration file: /HostAPd/hostapd-WEP-prism.conf
Opening raw packet socket for ifindex 8
BSS count 1, BSSID mask ff:ff:ff:ff:ff:ff (0 bits)
SIOCGIWRANGE: WE(compiled)=22 WE(source)=18 enc_capa=0xf
RATE[0] rate=10 flags=0x42
RATE[1] rate=20 flags=0x42
RATE[2] rate=55 flags=0x40
RATE[3] rate=110 flags=0x40
Could not set passive scanning: Unknown error 4294967295
Flushing old station entries
Deauthenticate all stations
Using interface eth0 with hwaddr 00:0e:8e:07:df:d6 and ssid 'teq'
eth0: RADIUS Authentication server
eth0: RADIUS Accounting server
IEEE 802.1X: New default WEP key index 2
IEEE 802.1X: New default WEP key - hexdump(len=13): [REMOVED]
eth0: RADIUS Sending RADIUS message to accounting server
   Attribute 40 (Acct-Status-Type) length=6
      Value: 7
   Attribute 45 (Acct-Authentic) length=6
      Value: 1
   Attribute 32 (NAS-Identifier) length=9
      Value: 'slackap'
   Attribute 30 (Called-Station-Id) length=23
      Value: '00-0E-8E-07-DF-D6:teq'
   Attribute 49 (Acct-Terminate-Cause) length=6
      Value: 11
eth0: RADIUS Next RADIUS client retransmit in 3 seconds

eth0: Setup of interface done.
Wireless event: cmd=0x8b1a len=12
eth0: RADIUS Received 20 bytes from RADIUS server
eth0: RADIUS Received RADIUS message
RADIUS message: code=5 (Accounting-Response) identifier=0 length=20
eth0: STA 00:00:00:00:00:00 RADIUS: Received RADIUS packet matched
with a pending request, round trip time 0.18 sec

I've tried different kernel as well - 2.6.26 - same thing happening.
I've also tried to put the following:

# Default hostap to managed mode
options hostap_pci iw_mode=2


# Default hostap to managed mode
options hostap_pci iw_mode=3

...into the /etc/modprobe.conf
No luck.

Can You please advise?


More information about the Hostap mailing list