help this poor girl,

Pavel Roskin proski
Thu May 8 09:40:11 PDT 2008

Hello, Jennie!

Please avoid such subject lines.  They are misused by spammers and

On Thu, 2008-05-08 at 06:11 -0700, jennie susan wrote:

> i am trying to setup an environment where i  control access to the
> network. i have set up an local area network. with a radius server,
> and a linux node i have to run wpasupplicant client to pass
> authentication. i am using ubuntu gusty, where network manager takes
> control of everything... everything works fine.... but i wanted to set
> (test) my own wpa supplicant, so i disabled the wpa_supplicant. i
> created a wpa_supplicant conf file with following details
> network={
> ssid="testnet"
> proto=WPA
> key_mgmt=WPA-PSK

WPA-PSK is for preshared key, not for RADIUS server.

> and my output when i run the wpa_supplicant
> jennianand at jennianand:~$ sudo wpa_supplicant -w -Dndiswrapper -iwlan0
> -c/etc/wpa_supplicant.conf -dd
> Driver does not support WPA.
> Association request to the driver failed

As far as I know, specific ndiswrapper support in wpa_supplicant is
broken.  I suggest that you try -Dwext instead of -Dndiswrapper, it may
actually work.

> it say driver doesnot support wpa, but i had been worked with network
> manager for 2 months without nay problem....

I think NetworkManager users -Dwext for all drivers.  When running
NetworkManager, you can run "ps auxwww | grep wpa" to see the actual
command line.

> here is my wireless card details
> *-network
>        description: Wireless interface
>        product: BCM4312 802.11a/b/g

This works just fine with the current kernel driver (b43).  You can try
it without upgrading the kernel is you use compat-wireless:

> physical wireless
>        configuration: broadcast=yes driver=ndiswrapper+bcmwl5
> driverversion=1.45+Broadcom,10/12/2006, 4.100. ip=
> latency=0 link=yes module=ndiswrapper multicast=yes wireless=IEEE
> 802.11g

That's a very old version of ndiswrapper, by the way.  The current
version is 1.52.  Another thing to try.

> [   19.312000] wlan0: encryption modes supported: WEP; TKIP with WPA,

That's a good sign that you simply have wpa_supplicant miscommunicating
with ndiswrapper.  -Dwext is likely to help.

> filename:       /lib/modules/2.6.22-14-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko

This kernel should be supported by compat-wireless.

> jennianand at jennianand:~$ ndiswrapper -l
> bcmwl5 : driver installed
>         device (14E4:4312) present (alternate driver: bcm43xx)

> and i already black listed bcm43xx

Well, bcm43xx might be another thing for you to try, but it's obsoleted
by b43 in the current kernel, so if it doesn't work, you are on your

> i have no clue, whats happing, i havnt installed wpa_supplicant
> myself, it was in my system already. 

I'm almost certain that -Dndiswrapper is broken in wpa_supplicant.

> any help, any hint, will be apperciable.... dont push me to ask ubuntu
> forum, i have tried everything no luck..... plz help me... i ahve to
> finish this fo rmy thesis which is due in a week.

Nobody is pushing you to the forum.  If you feel that your question is
more about WPA, ask in hostap at  If your question is
about ndiswrapper, ask in ndiswrapper-general at  If
your question is about b43 or another _free_ driver, then please ask

Pavel Roskin

More information about the Hostap mailing list