build wpa_supplicant on NetBSD?

Dan Williams dcbw
Wed Dec 10 11:05:07 PST 2008

On Wed, 2008-12-10 at 12:59 -0600, Jeremy C. Reed wrote:
> Trying to find instructions for building on NetBSD 4.0.
> (As discussed in previous email, my wpa_supplicant 0.4.9 is becoming 
> disassociated frequently so I want to upgrade to see if anything is 
> fixed.)
> I have tried 0.6.6 and 0.5.11.
> The README should indicate it needs GNU make (gmake).
> Does anyone have correct .config lines for NetBSD?
> Are any patches required for NetBSD?
> (Not easy to check in NetBSD's own cvs as my connection is dropping 
> everytime I attempt to look.)
> I have tried many things. My latest errors are:

This is because 'driver_hostap' is a Linux specific driver, like
driver_wext and a few others.  You probably just want to enable
'driver_bsd' and 'driver_wired' in your .config, and leave the rest out.


> -DEAP_TLS_FUNCS -I. -I../utils -I../hostapd -DCONFIG_BACKEND_FILE 
> driver_hostap.o driver_hostap.c
> driver_hostap.c: In function 'hostapd_ioctl':
> driver_hostap.c:44: error: 'struct iwreq' has no member named 'ifr_name'
> driver_hostap.c:48: error: 'SIOCDEVPRIVATE' undeclared (first use in this 
> function)
> driver_hostap.c:48: error: (Each undeclared identifier is reported only 
> once
> driver_hostap.c:48: error: for each function it appears in.)
> driver_hostap.c: In function 'prism2param':
> driver_hostap.c:90: error: 'struct iwreq' has no member named 'ifr_name'
> driver_hostap.c: In function 'wpa_driver_hostap_reset':
> driver_hostap.c:254: error: 'struct iwreq' has no member named 'ifr_name'
> gmake: *** [driver_hostap.o] Error 1
> _______________________________________________
> HostAP mailing list
> HostAP at

More information about the Hostap mailing list