Fedora7, WPA_supplicant, madwifi not working

Igor Chudov ichudov
Fri Sep 21 08:38:58 PDT 2007

I have a problem on which I already spent several days. I have a WPA
based AP. I run Fedora 7 on my Acer laptop and use Atheros based
internal Wifi card. It worked OK with WEP. However, WEP is no longer
acceptable. So I am converting to WPA. 

A Windows XP laptop (my wife's) connects to WPA just fine. 

However, wpa_supplicant v. 5.7 does not seem to connect. It goes
through a long cycle of changing states 

such. The message that also appears is "authentication timed out",
however, I am not sure why it times out. 

I can only test this in evenings, but right now I installed dev
versions of BOTH madwifi trunk, as well as dev version of
wpa_supplicant 6.0. I compiled and installed both and will try

Any words of wisdom will be appreciated.

I will post more as more details emerge. 

I am especially interested in finding ANYONE who managed to make WPA
work with Atheros based cards.



More information about the Hostap mailing list