Problem when compiling latest hostapd against wireless-dev and latest libnl

Andrea Lusuardi - UoVoBW linolusu
Thu Sep 6 05:53:43 PDT 2007

Hi everyone,
i am trying to build the latest hostap git sources against the latest
wireless-dev kernel. I already donwloaded and installed the libnl
library (from svn), but i still get a strange compilation error:

cc -MMD -O2 -Wall -g -DHOSTAPD_DUMP_STATE -I../src -I../src/crypto
-I../src/utils -I../src/common -I/usr/src/wireless-dev/net/mac80211
driver_devicescape.o driver_devicescape.c 
driver_devicescape.c: In function 'nl80211_remove_iface':
driver_devicescape.c:813: error: 'NL80211_CMD_DEL_VIRTUAL_INTERFACE'
undeclared (first use in this function) 
driver_devicescape.c:813: error: (Each undeclared identifier is
reported only once 
driver_devicescape.c:813: error: for each function it appears in.)
driver_devicescape.c:814: error: 'NL80211_ATTR_IFINDEX' undeclared
(first use in this function) 
driver_devicescape.c: In function 'nl80211_create_iface':
driver_devicescape.c:838: error: 'NL80211_CMD_ADD_VIRTUAL_INTERFACE'
undeclared (first use in this function) 
driver_devicescape.c:839: error: 'NL80211_ATTR_IFINDEX' undeclared
(first use in this function) 
driver_devicescape.c:841: error: 'NL80211_ATTR_IFNAME' undeclared
(first use in this function) 
driver_devicescape.c:842: error: 'NL80211_ATTR_IFTYPE' undeclared
(first use in this function) 
make: *** [driver_devicescape.o] Error 1

(sorry for the crappy paste, i tried to indent it but the wrap is more

I have the wireless-dev tree in place and correctly configured, i have
the libnl installed:

uovobw at electricmove:~$ file /usr/local/lib/libnl* 
/usr/local/lib/          symbolic link to `' 
/usr/local/lib/        symbolic link to `' 
/usr/local/lib/ ELF 32-bit MSB shared object, PowerPC
			or cisco 4500, version 1 (SYSV), not stripped

and the correct includes in place:

uovobw at electricmove:~$ls /usr/local/include/netlink/ 
addr.h  attr.h  cache.h  data.h fib_lookup  genl  handlers.h  list.h
msg.h netlink-compat.h netlink.h  netlink-kernel.h  object.h  route
socket.h  types.h  utils.h

I think i configured correctly the config (comments snipped)

CFLAGS += -I$(WIRELESS_DEV)/net/mac80211
CFLAGS += -I/usr/local/include/
LIBS += -L/usr/local/lib

and until the introduction of this new nl library everything compiled
and worked fine. Any hints where to look for errors? A big fat rtfm
about linking and making the compiler find the correct symbols? I tried
grepping for the erroring token (NL80211_CMD_DEL_VIRTUAL_INTERFACE ) in
bot the include and the source dir of libnl, but i could not find it...
Thanks a lot for the help and for the mighty hostapd :) 

           Andrea Lusuardi  -  UoVoBW 
          Registered Linux User #364578 - GPG: 313C1073
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 827 bytes
Desc: not available
Url : 

More information about the Hostap mailing list