Fwd: Need help. Trying to get a new driver work.

Sriharsha Vedurmudi svedurumudi
Wed Oct 3 13:15:14 PDT 2007

Looks like I caught the problem. I was probably re-constructing the
WPA IE (after the probe response was decoded, our private structure is
populated with the details of the wpa ie, using which I am
re-constructing the IE) in a wrong way.

The progress now is that the station is authenticating with the AP,
but when it is trying to associate, the AP is responding with the
status code 13 (Responding station does not support the specified
auth...). Or so says OmniPeek (that we are using for a sniffer). The
error looks strange though because authentication already happened.

Anyway, thanks a million times Dan, I now know where to look. If Im
stuck again, I'll ping you.

Best regards,

On 10/3/07, Dan Williams <dcbw at redhat.com> wrote:
> On Wed, 2007-10-03 at 23:51 +0530, Sriharsha Vedurmudi wrote:
> > I just tried by replacing IWEVGENIE with IWEVCUSTOM, still no success.
> > wpa_supplicant simply refuses to recognize WPA IE. Any thought what
> > else could possibly go wrong?
> Can you put a few wpa_printf (MSG_INFO, "...") statements in
> wpa_driver_wext_get_scan_results() inside the case IWEVGENIE block to
> figure out where it's dropping out of that block?  Lets try to narrow
> down exactly _why_ wpa_supplicant doesn't think the driver is returning
> a WPA IE for the BSS.
> Dan
> > Regards,
> > Sriharsha.

More information about the Hostap mailing list