version 4.9 hostapd returns segmentation fault on IXP425

hong zhang henryzhang
Tue Mar 20 21:24:43 PDT 2007

On Mon, Mar 19, 2007 at 08:45:55PM -0700, hong zhang wrote:

>>   Version 4.9 hostapd will cause segmentation fault sometimes on 
IXP425--Gatework 2348 board. The chance is 50%. When I run "hoastapd 
ap_conf", it returns following even after I do "echo 2 > 
/proc/cpu/alignment". See following errors message,
> >   
> >  Bad mode in data abort handler detected: mode IRQ_32
> >  Internal error: Oops - bad mode: 0 [#1]
> >  Modules linked in: wlan_ccmp wlan_acl wlan_tkip wlan_xauth wlan_wep 
ath_pci ath_hal ath_rate_onoeCPU: 0
>>   PC is at 0xffff0204
>>   LR is at zz002db51c+0x44/0x3b4 [ath_hal]

>I've tested hostapd on ixp425, but have not seen something like this
>show up. Then again, I haven't tested it with madwifi driver on ixp425.
>This kernel oops looks more like an indication of a bug in the kernel
>driver (maybe in ath_hal module) than an issue in hostapd.. Have you
>tried using this device as an AP without hostapd (e.g., in plaintext
>mode and configure the interface with iwconfig and ifconfig)?
>Jouni Malinen                                            PGP id 
  Yes, I set this device as AP without hostapd and never has this problem.
  I can ifconfig ath0 up, iwconfig ath0 and iwconfig ath0 channel 1, etc.. I am going to run hostapd with plain mode tomorrow.

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Hostap mailing list