wpa_supplicant: authentication timeout problem

Jagadish jagadish.nadimpalli
Wed Jun 20 03:55:10 PDT 2007

Hi everybody,

Our wireless client has atheros wireless card (madwifi-0.9.3 driver).  
The deployment, scenario and the problem I am facing are explained below.

There are two access points in range of wireless client.
(1) AP-1, configured with ssid: helloworld, Security mode: WPA2, channel:6)
(2) AP-2, configured with ssid: helloworld, Security mode: WPA2, 

Our requirement:
Our wireless client has to roam from AP-1 to AP-2 with minimal delay (In 
order of milli seconds).

The authentication timeouts in wpa_supplicant source code are set around 
200ms. I ran wpa_supplicant at client side
and associated to AP-1. After successful association with AP-1, I 
switched off AP-1. Now it disassociated with AP-1.
Now it has to associate with AP-2. But I am observing authentication 
timeouts (failed to authenticate) for some times. After some iterations 
it is able to associate with AP-2.
If I introduce one second delay after getting disassociation event (for 
AP-1) from the driver, I am able to associate
with AP-2 immediately after one second delay without any authentication 
I tried to introduce delay less than one second. Still I am getting 
authentication timeouts.

(1) Why authentication timeouts occurred without one second delay? Is 
this delay required (for some unknown reasons like key clean-up e.t.c.)?
(2) Is this a problem in madwifi driver or wpa_supplicant?


More information about the Hostap mailing list