RTS/CTS loop when in Promiscuous Mode

ahuguet at cttc.es ahuguet
Wed Jun 6 02:46:36 PDT 2007

> Promiscuous mode has number of issues and the exact behavior may depend
> on the used STA firmware version. This issue with RTS/CTS may be one of
> those issues..
> I've given up on trying to do anything with promiscuous mode
> with Prism2/2.5/3 cards. This would be a question for whoever is
> maintaining the firmware (if anyone) at this point. Though, I would not
> expect to get any answer.

Thank you again for your help Jouni.
It indeed seems a firmware related error.
Version 1.4.9 doesn't seem to handle this case correctly, however, I tried
flashing into RAM two cards to 1.7.4 and the problem seems to be solved.

Even though I'm not sure I'll be needing this RTS/CTS functionality for my
tests, truth is that there is indeed a firmware version already available
that seems to have solved that issue (so far I've tried it only once, but
I'd say the problem is gone with 1.7.4)

So my comments about not understanding why the RTS/CTS was auto-started at
3rd retry do not apply anymore, for the loop was caused due to using
promiscuous mode + 1.4.9 firmware.

Thank you once again for your help.

More information about the Hostap mailing list