wpasupplicant and multiple/hidden SSIDs

Dave Hansen dave
Mon Dec 17 10:06:19 PST 2007

On Fri, 2007-12-07 at 19:24 -0500, Dan Williams wrote:
> On Fri, 2007-12-07 at 16:09 -0800, Dave Hansen wrote:
> > On Fri, 2007-12-07 at 18:57 -0500, Dan Williams wrote:
> > > > The problem is that I don't think the scan_ssid=1 logic comes into
> > > play
> > > > until it finds an explicitly hidden ssid.  In my case, I think
> > > > wpasupplicant looks around and sees the ~10 "VISITOR" access points,
> > > > notes that it doesn't have any config entries for them, then
> > > promptly
> > > > ignores them. :(
> > > 
> > > You've tried scan_ssid=1 + ap_scan=1 already I take it?
> > 
> > Yeah, wpasupplicant doesn't try to associate because it sees that the
> > scan_ssid=1 network is a WPA network, yet the APs don't advertise WPA.
> That's odd, because it should be sending out a probe request anyway,
> getting the probe response with the IE back, and updating it's scan
> table.  At least, that's the way it's reasonable to expect that it would
> work.  I wouldn't expect it to ignore the scan_ssid=1 just because the
> network block doesn't match, because then what's the point of the
> scan_ssid=1 anyway...
> I assume you're not specifying the BSSID in the network block?

Sorry for the delay.  I've been too lazy to actually trouble myself to
drive into the office. :)

Here's exactly what I have:

plus a few other networks...

Here's some output from -d with wpasupplicant:

ctrl_interface_group='0' (DEPRECATED)
Priority group 7
   id=0 ssid='IBM'
Priority group 6
   id=3 ssid='Jella'
Priority group 5
   id=1 ssid='Commodore'
   id=2 ssid='GROOMLAKE'
EAPOL: External notification - portValid=0
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=3):
     49 42 4d                                          IBM             
Trying to get current scan results first without requesting a new scan to speed up initial association
Received 1123 bytes of scan results (5 BSSes)
Scan results: 5
Selecting BSS from priority group 7
0: 00:12:44:b8:f8:40 ssid='IBMVISITOR' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
1: 00:12:44:b8:fc:80 ssid='IBMVISITOR' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
2: 00:12:44:b8:fc:c0 ssid='IBMVISITOR' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
3: 00:12:44:b9:00:30 ssid='IBMVISITOR' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
4: 00:12:44:b8:fc:b0 ssid='IBMVISITOR' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE

I'd be happy to send you the entire -d output if it helps.

One odd thing that I've noticed is that the card comes back after
wpasupplicant associated with IBMVISITOR.  I run wpasupplicant like

	 iwconfig eth1 essid any; ./wpa_supplicant -c /root/wpa_supplicant.conf -i eth1 -Dwext   -d 

and it always comes back like this:

eth1      IEEE 802.11g  ESSID:"IBMVISITOR"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:12:44:B8:FC:B0   
          Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=67/100  Signal level=-60 dBm  Noise level=-85 dBm
          Rx invalid nwid:0  Rx invalid crypt:1339  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1950   Missed beacon:0

-- Dave

More information about the Hostap mailing list