feisty atheros and wpa

Ivica Ico Bukvic ico
Fri Aug 31 16:10:39 PDT 2007

Hi all,

I am using Ubuntu feisty (more precisely Ubuntu Studio) and here's my

*macbook pro santa rosa, 2.6.20-16 low latency kernel from Ubuntu Studio,
atheros driver ath_pci with madwifi 0.5.5 wpasupplicant, using nm-applet
*Wireless networks are detected (including WPA-enabled which interests me
the most)
*Connecting to WPA-enabled network has so far worked only once (I am unable
to recreate the scenario as it appears near random)
*tried using latest madwifi driver from svn trunk and 0.6.0 wpasupplicant
without success
*tried using wicd instead nm-applet without success
*manually running wpa_supplicant -Dwext (or -Dmadwifi which appears to a bit
farther) -iath0 -c/etc/wpa_supplicant.conf -dd gives me successful
authentication (AUTHENTICATED message) with appropriate settings in
wpa_supplicant.conf and /etc/network/interfaces which include WPA-PSK/TKIP
settings (WPA network I am trying to join is not advertising ESSID so I am
using scan_ap=2 and scan_ssid=1) but I still cannot connect
*I have no idea what settings nm-applet is running wpa_supplicant with--may
have to dig into the nm-applet's code

I'll try to send a detailed outputs from relevant files later, but was
wondering in the meantime if anyone had any ideas why and how is this
happening? Since I manually installed wpa_supplicant and latest madwifi
drivers, do I need to also install hostap as well (I suspect not but then
again what do I know :-)?

P.S. FWIWI it would be helpful to have some kind of a diagram which shows
hierarchy of what affects what as it appears that starting wpa_supplicant
manually collides with ifup commands (and vice-versa) while nm-applet is a
story in and of itself...

Many thanks!

Best wishes,

Ivica Ico Bukvic, D.M.A.
Composition, Music Technology, CCTAD, CHCI
Virginia Tech
Dept. of Music - 0240
Blacksburg, VA 24061
(540) 231-6139
(540) 231-5034 (fax)
ico at vt.edu

More information about the Hostap mailing list