Can't get hostap & wpasupplicant working on Thinkpad A31p with Prism 2.5 Wifi

Brian Hutchinson b.hutchman
Fri Aug 24 12:29:32 PDT 2007

Hi, I origally posted this to the wpasupplicant list and Kel suggested this
was a better place to get help with Prism 2.5 based cards.

Background.  I've been trying to get WPA going on my Thinkpad A31p for a
while.  Because I couldn't get WPA working, recently I did the BIOS patch
that would allow me to use a non IBM wifi card.  The only other card I had
was a Winston CM-9 (Atheros) and I had madwifi and wpa supplicant running
great.  Problem is my laptop saw it as another Ethernet controller and would
fight and be unstable.  Every time I would apply power it would try to PXE
boot etc. so I had to go back to trying to get the Prism 2.5 radio working.

So to recap, I was able to associate and get connectivity with madwifi & wpa
supplicant.  With the Prism card, my first problem was it had old firmware
and I finally figured out how to upgrade (couldn't find the PDA files was my
problem for the longest time) the Primary and Station firmware and I now
have what is reported below.

hostap_diag reports:
NICID: id=8013 v1.0.0 (PRISM II (2.5) Mini-PCI (SST parallel flash))
PRIID: id=0x0015 v1.1.1
STAID: id=0x001f v1.7.4 (station firmware)

For some reason dmesg shows the card showing up as wifi0 and then I see a
line where wifi0:  registered netdevice wlan0
Then I see a line where udev renamed wlan0 to eth2 and when I do a iwconfig
I see my wireless card showing up twice under the names  eth2 and
wlan0_rename.  I think I need to work on some udev rules to fix this ... I
guess it should be called wlan0.

My interfaces file looks like this:
auto eth2
iface eth2 inet dhcp
   wpa-driver hostap (have tried wext or just nothing and I get the same
   wpa-bssid 00:12:a9:d1:e1:2e
   wpa-pairwise TKIP CCMP
   wpa-group TKIP CCMP
   wpa-key-mgmt WPA-PSK
   wpa-auth-alg OPEN SHARED LEAP
   wpa-sid mysid
   wpa-psk mypsk
   wpa-proto WPA RSN
   wpa-ap-scan 1 (have tried 2 as well)

kernel is 2.6.22  and I can provide .config if needed.  At first hostap,
hermes, and prism_pci were showing up in the modules list and I read where
they need to be black listed so rather I rebuilt the kernel again to not
include these and now hostap is the only one that shows up loaded in the
modules list.  lsmod | grep hostap has hits on these modules being loaded:
hostap_pci, hostap and ieee80211_crypt

On bootup, the interface tries to come up but DHCP never gets a response.  I
have firewall rules that allows the wireless traffic not to get blocked
(again this all worked with madwifi & an Atheros card so I know my rules

I run iwevent in another window and the only event I see is the station mode
being set to Managed.  I don't see anything else.

I do a ps and grep for wpa and I see that wpa_supplicant is running.  I've
tried it with both the wap-driver hostap and wext.

I have a mixed system of testing & unstable.  wpa-supplicant is 0.6.0-2.
wireless tools is the latest, version 29 which I had to download and compile
myself to get rid of the warnings of iwconfig etc. being a different version
from the extensions in the kernel.

Can someone point me in the direction I should go to debug this further?
Let me know what other information you need and I'll provide it.

I'd like to see someones .config for a recent kernel like 2.6.22 too so I
can double check I configured everything in the kernel right.

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Hostap mailing list