[hostap driver] not authenticating when used w/ wpa-supplicant / network-manager

Dan Williams dcbw
Wed Aug 15 12:57:23 PDT 2007

On Wed, 2007-08-15 at 15:01 -0400, Tony Espy wrote:
> Dan Williams wrote:
> > On Tue, 2007-08-14 at 15:59 -0600, Andrew Jorgensen wrote:
> >> On 8/14/07, Andrew Jorgensen <andrew.jorgensen at gmail.com> wrote:
> >>> Also, in another thread you advised the user to use the wext driver
> >>> against hostap_*.  Is that the preferred driver for current versions
> >>> of hostap_*?  There's a patch in the Ubuntu network-manager that sets
> >>> the wpa-supplicant driver to hostap if the device driver is hostap_*.
> >>> They can try taking that out if it should work better.
> >> Using the wext driver doesn't appear to change anything.  Anything
> >> else I can do to debug this?
> >>
> >> Also, I've read reports elsewhere that wpa-supplicant has worked with
> >> the hostap driver and the 1.7.1 firmware.  Even more reports that it
> >> works with 1.5.6 firmware, which I have also tried.
> The original Pepper Pad 2 used a modified versions of the hostap driver 
> and wpa_supplicant ( both v0.4.7 ).  As long as the card's STA firmware 
> was >= 1.7.1, things worked just fine with WPA/WPA2 access points.
> I'm pretty sure WPA support was added in 1.7.1 of the STA fw, not 1.5.6, 
> however I could be wrong.  The WiFi cards we received from Gemtek for 
> the original Pepper Pads were shipped with STA fw 1.4.9 which I know for 
> a fact didn't support WPA, so we had to upgrade them on-the-fly to 1.8.X.
> Also, I tried an experiment on my PP2 starting wpa_supplicant with 
> -Dhostap vs. -Dwext and this made no difference in behavior with respect 
> to WPA/WPA2 access points.
> Please note however that the Pepper Pads are *not* running 
> NetworkManager.  I think there may be a bug in NetworkManager with 
> respect to the hostap driver and WPA/WPA2.  As I understand it, 
> NetworkManager talks to the drivers directly to handle scanning versus 
> the Pepper software which lets wpa_supplicant handle scanning.

Recent versions of NetworkManager request that wpa_supplicant scan, but
receives scan results via SIOCGIWSCAN ioctl.  That's no different than
running iwlist eth0 scan at the same time as wpa_supplicant.

NM trunk (what will be 0.7) uses the D-Bus interface to wpa_supplicant
and does all scanning through wpa_supplicant.


> I have a laptop running the latest version of Ubuntu Gutsy which has a 
> Prism card...I just upgraded the STA firmware to 1.8.4 and now NM 
> doesn't list our Airport Extreme ( configured as WPA2 ) in it's scan 
> results.  Before I upgraded the STA fw, the Airport showed up 
> incorrectly as a WEP access point.
> I haven't had a chance to dig any further.
> Ciao,
> /tony
> Pepper Computer
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap

More information about the Hostap mailing list