help for error after changing mode

YAN HE yanhe
Thu Aug 2 21:10:58 PDT 2007

Hello, Everybody,

I met a strange problem in using hostap driver 0.4.9 for Prism cards. After I inserted the card, the driver could recognize the card and showed the general information after I ran "iwconfig wlan0". However, after I ran "iwconfig wlan0 mode Managed", the essid became empty(""). After that, whatever essid I assigned by running "iwconfig wlan0 essid essidname", the essid was always empty. When I ran "iwlist wlan0 scan", I got the error message "wlan0     Interface doesn't support scanning : Network is down". 

The version of linux kernel is 2.6.11. I tried both Netgear MA401 16-bit card and D-Link DWL650 16-bit card, and got the same error. The detailed output is attached.

Thanks a lot.

-------------- next part --------------
An HTML attachment was scrubbed...
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: typescript.txt

More information about the Hostap mailing list