Is this setting correct?

Nicholas Chan nicholas.putfile
Sat May 27 08:39:45 PDT 2006

Hi i'm trying to setup an adhoc network using wpa. group=TKIP worked
perfectly for me but i would like to try group=CCMP.

 i edit /etc/wpa_supplicant.conf



 # IBSS/ad-hoc network with WPA-None/TKIP.
 group=CCMP    # i tried group=TKIP and it worked perfectly but i
would like to try   CCMP

 when i ran wpa_supplicant -Bw -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf -d

 It gave me this error

Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
Line 21: removed CCMP from group cipher list since it was not allowed
for pairwise cipher
Priority group 0
id=0 ssid='testwpa'
Initializing interface (2) 'ath0'
ioctl[SIOCSIWMODE]: Invalid argument
Could not configure driver to use managed mode
SIOCGIWRANGE: too old (short) data - assuming WPA is not supported
Own MAC address: 00:13:46:93:8a:e5
wpa_driver_madwifi_del_key: keyidx=0
wpa_driver_madwifi_del_key: keyidx=1
wpa_driver_madwifi_del_key: keyidx=2
wpa_driver_madwifi_del_key: keyidx=3
wpa_driver_madwifi_set_countermeasures: enabled=0
wpa_driver_madwifi_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Added interface ath0
Ignore event for foreign ifindex 3
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
Trying to associate with SSID 'testwpa'
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: No WPA/RSN IE available from association info
WPA: Set cipher suites based on configuration
WPA: Selected cipher suites: group 0 pairwise 1 key_mgmt 16
WPA: clearing AP WPA IE
WPA: clearing AP RSN IE
WPA: Failed to select group cipher.
WPA: Failed to set WPA key management and encryption suites (no scan results)
Wireless event: cmd=0x8b19 len=12
Received 206 bytes of scan results (1 BSSes)
Scan results: 1
RX ctrl_iface - hexdump_ascii(len=6):
41 54 54 41 43 48 ATTACH
CTRL_IFACE monitor attached - hexdump(len=21): 2f 74 6d 70 2f 77 70 61
5f 63 74 72 6c 5f 39 31 30 31 2d 30 00
RX ctrl_iface - hexdump_ascii(len=4):
50 49 4e 47 PING
RX ctrl_iface - hexdump_ascii(len=6):
53 54 41 54 55 53 STATUS
RX ctrl_iface - hexdump_ascii(len=4):
50 49 4e 47 PING
RX ctrl_iface - hexdump_ascii(len=4):

 Could anyone help me with this? Why is CCMP not allowed for pairwise
cipher? Am i missing out something here?


More information about the Hostap mailing list