ConnectPlus: simultaneous use of memory and wi-fi?

Jouni Malinen jkmaline
Wed Jun 21 21:00:13 PDT 2006

On Fri, Jun 16, 2006 at 03:44:48PM -0400, Andrew Barr wrote:

> I have a Zaurus SL-5600 handheld which is currently running kernel 2.6.16. If 
> this scenario is possible under 2.4 I'd like to revert to 2.4.18. I am trying 
> to configure a SanDisk ConnectPlus card to use the wi-fi part (in monitor 
> mode with Kismet) and the memory part (to store logs) at the same time. I 
> have been unable so far to get this to even work on my x86 laptop running 
> 2.6.16. If I insert the card, I can get either hostap_cs to work or ide_cs to 
> work, but not both. I think which works depends on which loads first. If I 
> just insert the card without inserting one of those modules first, hostap_cs 
> loads and this appears in the kernel log:
> 0.1: GetNextTuple: No more items
> If I eject the card via 'pccardctl eject' and then re-insert it 
> with 'pccardctl insert', hostap_cs again initializes but the message is 
> different:
> pcmcia: registering new device pcmcia0.1
> 0.1: ParseTuple: Bad CIS tuple

I can reproduce this in on my laptop (also a Thinkpad with Linux
2.6.16). Interestingly enough, I was unable to return to the earlier
behavior of just ide_cs being initialized. I tried removing all the
loaded modules and physically ejecting the card, but still, hostap_cs
seems to be initialized first on all future attempts and that
initialization fails (driver seems to be seeing unexpected interrupts)
with the "Bad CIS tuple" error as the end result. That is kind of
surprising error, since CIS seems to be valid.

> Is this even possible with the current Linux kernel? If it is, is it possible 
> under Linux 2.4? The Zaurus has some minor issues (hardware suspend key 
> doesn't trigger suspend, sound isn't working, etc.) with the 2.6 test images 
> right now so I'd like to go back to the tried-and-true 2.4.18 image if at all 
> possible.

I don't think I've tried this with the new PC Card code in Linux 2.6. I
know that it is possible to get both functions working at the same time
on at least some systems. However, it wasn't easy. I've seen this
working on one laptop so far and it took quite some time getting
everything configured in a way that resource did not conflict and
interrupts were working.. I don't remember which kernel version I was
using, but I would assume it was one of the earlier Linux 2.6.x kernels.

I would expect this to be more of a generic pcmcia question, though, so
pcmcia mailing list may indeed be better place for the question as was
mentioned before. If there is any indication of this being somehow
specific to Host AP driver, I have the SanDisk card and I can reproduce
this issue easily, so I should be able to take a closer look.

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list