PTK cipher mismatch

Mihai Maties mihai
Thu Jun 8 23:08:30 PDT 2006

On Friday 09 June 2006 06:37, Jouni Malinen wrote:
> On Wed, Jun 07, 2006 at 10:06:28AM -0400, Dan Williams wrote:
> > Can you post the section of your config file that refers to the AP(s)
> > you are attempting to connect to?
> That would indeed be easier than having to parse debug log to figure out
> what was configured.

OK, the configuration file that _worked_ in the past follows:


I'm pretty sure the wireless network configuration didn't change, the only 
things that did change are: the kernel version (2.6.12 -> 2.6.15) and 
wpa_supplicant version (0.4.5 -> 0.4.8).

> Anyway, the problem seems to be in the configuration trying to use
> non-WPA mode with TKIP, if I understood it correctly. If the purpose was
> to use LEAP with TKIP (Cisco specific mode..), key_mgmt needs to be set
> to WPA-EAP, not IEEE8021X. Mihai, if this was not the case, please send
> the configuration block and describe how the AP is configured.

I cannot describe the AP configuration since I do not have access to it, but 
if you are interested in a specific parameter tell me and I'll try to figure 
it out from a friend that uses Windows (the parameters are configured 

I followed your suggestions and changed the config file to:


... but from my point of view the things are pretty much the same: "PTK cipher 
mismatch". I attached the debug log, maybe it helps.

One more thing: in the 0.4.8 version I see now some parameters related to 
opensc engine. Could this be an issue ? I tried setting these parmaters to 
some libraries that seem to be what the program needs but still no luck.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: jouni.conf.log
Type: text/x-log
Size: 8192 bytes
Desc: not available
Url : 

More information about the Hostap mailing list