HostAP and WPA2 with Intersil Prism card

Alex Pounds alex
Thu Dec 14 16:13:02 PST 2006

On Wed, Dec 13, 2006 at 07:59:45AM -0500, Dave Neuer wrote:
> Once you rebuild, install and reboot the new kernel, you can then run
> the prism2_srec utility to flash the card. Note, apparently because of
> some inconsistency between the driver, utilities and debian's udev
> setup, you will need to explicitly tell prism2_srec where the PDAs are
> (e.g., prism2_srec -v eth<n> -O /proc/net/hostap/wlan0/pda <primary
> firmware>.hex <station firmware>.hex).

Well, I have since updated my firmware (which went OK), but I am now
having problems. Different problems. I used the following command to
update my firmware: 

prism2_srec -f -v eth0 -O /proc/net/hostap/wlan0/pda pk010101.hex sf010804.hex

This reported everything went fine; running hostap_diag eth0 also reported
everything as going fine. I then tried to get wpa_supplicant on the go. On
my desktop, I don't do things "properly" to get my wifi back after a
reboot - I've got the following shell script that's called from an init

iwconfig ath0 ap AA:BB:CC:DD:EE:C8
iwconfig ath0 essid "wireless"
iwconfig ath0 channel 1
iwpriv ath0 bgscan 0
iwpriv ath0 wpa 3
wpa_supplicant -Bw -Dwext -iath0 -c/etc/wpa_supplicant.conf
dhclient ath0

I tried this, but using wlan0_rename as my parameter and using the
following wpa_supplicant line: 

wpa_supplicant -Bw -Dhostap -iwlan0_rename -c/etc/wpa_supplicant.conf

To be honest, there was some futzing involved with some commands using
eth0 and some as wlan0_rename as the interface name. I've managed to tie
myself in knots this way before, and decided to reboot. And that is where
the fun begins. The interface doesn't come back up on reboot, though both
the hostap and hostap_pci modules are shown as loaded. If I rmmod them
both and then modprobe hostap_pci, I get the following: 

hostap_pci: 0.4.4-kernel (Jouni Malinen <jkmaline at>)
PCI: Enabling device 0000:01:02.0 (0110 -> 0112)
ACPI: PCI Interrupt 0000:01:02.0[A] -> Link [LNKC] -> GSI 11 (level, low) - > IRQ 11
hostap_pci: Registered netdevice wifi0
wifi0: Interrupt delivery does not seem to work
hostap_pci: Initialization failed
ACPI: PCI interrupt for device 0000:01:02.0 disabled 

The kernel.log reveals a similar story, but after the "Registered
netdevice wifi0" line the following are given: 

wifi0: Original COR value: 0x21
prism2_hw_init: initialized in 192 ms
wifi0: hfa384x_cmd: entry still in list? (entry=df211b20, type=0, res=0)
wifi0: hfa384x_cmd: command was not completed (res=0, entry=df211b20, type=0, cmd=0x0021, param0=0xfd0b, EVSTAT=8010 INTEN=0010)
wifi0: interrupt delivery does not seem to work
wifi0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd0b, len=8)
Could not get RID for component NIC

And then the rest is as above. So, what's the story? How do I get my
module loading again, and when I've done that how am I supposed to get
wpa/wifi going? 

Thank you, 
Alex Pounds (Creature)                  .~.
                                       // \\
"Variables won't; Constants aren't"   /(   )\

More information about the Hostap mailing list