Primary Prism firmware not able to be parsed

Pavel Roskin proski
Thu Jun 9 16:23:38 PDT 2005


On Thu, 2005-06-09 at 14:21 -0700, Morgan McDermott wrote:
> I recently got a D-link DWL-520 (Rev. E1) wireless card, and I found a
> great tutorial
> ( )
> on setting up this card under linux (I'm running Slackware 10.0).
> Everything has worked fine except when I tried to run hostap_fw_load,
> I recieved the error:
> # hostap_fw_load wlan0
> Downloading Primary Firmware /etc/firmware/PM010102.HEX
> '/etc/firmware/PM010102.HEX' not readable.
> Parsing '/etc/firmware/PM010102.HEX' failed.

Try this patch:

--- prism2_srec.c
+++ prism2_srec.c
@@ -802,7 +802,7 @@ struct srec_data * read_srec(const char 
 	f = fopen(fname, "r");
 	if (f == NULL) {
-		printf("'%s' not readable.\n", fname);
+		printf("'%s' not readable: %s.\n", fname, strerror(errno));
 		return NULL;
prism2_srec will tell you why it fails to open the file.  Most likely
the file doesn't exist (how hard was it to check before asking in the

By the way, the patch should be OK for applying it to CVS.

P.S. The tutorial is wrong.  Since it recommends taking files from my
collection, the lines in hostap_fw_load should be:


I use only lower-case names in the collection.  The copy goes to Andrew
Barr.  Also, I would recommend changing 1.8.0 to 1.8.3 and 010800 to
010803 throughout the document because 1.8.3 is the latest RAM firmware
for Prism 2.5/3.

Pavel Roskin

More information about the Hostap mailing list