Hostap (Managed Mode) Signal Quality Problem

Tony Espy espy
Thu Jan 6 16:08:40 PST 2005

I'm having trouble with the hostap-driver (v0.2.5) running in managed 
mode where the signal quality values never seem to change when retrieved 
via /proc/net/wireless interface, nor the SIOCGIWSTATS ioctl.

Sometimes they work ( ie. the values change over time ), but most of the 
time, the values are static.  The other values reported by the iwconfig 
& /proc/net/wireless seem to update OK ( eg. discarded packets, etc... ).

I'm running a 2.4.20 kernel w/the WE15 patch on an Xscale CPU.  I've 
reproduced the problem with both a Gemtek CF card ( PRI=v1.1.0 / 
STA=1.7.4) and a Linksys CF card ( PRI=v1.1.1 / STA=v1.8.0 ).

I added some printk's in the prism2_update_comms_qual() method to ensure 
that the get_rid() call wasn't failing and that doesn't seem to be the 
case.  I also tried disabling the comms_qual_update task, but this had 
not effect either.

I have not yet tried v0.2.6 yet, but plan to do so tomorrow.

Any help, and/or hints for further debugging would be most appreciated!

Tony Espy
Pepper Computer

More information about the Hostap mailing list