hostap/hostapd/wpa_supplicant - new development release v0.3.3

Miles Lane miles.lane
Mon Jan 3 23:21:35 PST 2005

On Mon, 3 Jan 2005 20:57:34 -0800, Jouni Malinen <jkmaline at> wrote:
> On Mon, Jan 03, 2005 at 01:38:59PM -0800, Miles Lane wrote:
> > Is the Broadcom driver buildable?  If so, is it required for me to get
> > WPA-PSK working on my BCM4306-based PCI card?  I am trying to connect
> > to an Airport Extreme access point.  Currently, I have the binary
> > drivers loaded using ndiswrapper and I tried using wpa_supplication
> > wlan0 -Dndiswrapper, but it failed to set up a WPA-PSK connection.
> What do you mean with "Broadcom driver"? Do you have some source code
> that could be built? For x86?
> Which version of ndiswrapper are you using? Please test with the latest
> version and send debug log messages showing that failed connection.

Hello Jouni,

I was referring to:


Described in the README as:
	Broadcom wl.o driver
	This is a generic Linux driver for Broadcom IEEE 802.11a/g cards.
	However, it is proprietary driver that is not publicly available
	except for couple of exceptions, mainly Broadcom-based APs/wireless
	routers that use Linux. The driver binary can be downloaded, e.g.,
	from Linksys support site (
	for Linksys WRT54G. The GPL tarball includes cross-compiler and
	the needed header file, wlioctl.h, for compiling wpa_supplicant.
	This driver support in wpa_supplicant is expected to work also with
	other devices based on Broadcom driver (assuming the driver includes
	client mode support).

By the way, I notice that a few more files are needed from the WRT54G
tarball.  Specifically, both wlioctl.h and driver_broadcom.c reference
typedefs.h.  I found several copies in the WRT54G tarball and tried using
the one from the linux/include/linux directory, if I recall correctly.
I found that wlioctl.h also wants to include:
#include <proto/ethernet.h>
#include <proto/802.11.h>
I found copies of these files in the WRT54G tree, but I am not sure
where I should have
found these files.

I thought that building this driver is what is enabled with:


I am using ndiswrapper-0.12 built from source.

The binary driver I am loading for the Motorola WPCI810GP

I found the following info at:
Card: Motorola WPCI810G PCI Adapter
Chipset: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
pciid: 14E4:4320
Windows Driver:
Other: This card works with ndiswrapper 0.12 using the "bcmwl5.inf"
driver obtainable at Motorola above.
Had to set "Country|US" and "SSID|<your ESSID>" in
Motherboard is ASUS CUBX with wlan0 in shared first shared ISA/PCI
slot. If other PCI cards are installed wlan0 does not come up and but
no error messages reported (LED does not blink at all, nothing to
stdout, syslog, etc., even with DEBUG=3 when building ndiswrapper.ko).
Distro is stock Fedora Core 3 with kernel 2.6.9-1.667.

Again, I am running Debian-Unstable.  The person who wrote the
preceding note forgot to mention whether he managed to get WPA-PSK

More information about the Hostap mailing list