wpa_supplicant associates but dhcpcd cannot get IP address

Craig L gangis
Sun Feb 6 12:46:41 PST 2005

Wow. Adding -wq and then letting it daemonize solved the problem
perfectly! Thanks a bunch for your help. :D



On Sun, 6 Feb 2005 12:32:48 -0800, Jouni Malinen <jkmaline at cc.hut.fi> wrote:
> On Sun, Feb 06, 2005 at 02:43:21PM -0500, Craig L wrote:
> > Apparently changing ap_scan to 1 and not letting it daemonize worked.
> > I shut it off, added the -Bw switch to let it daemonize and I'm still
> > experiencing the same issue. I then removed -Bw and tried again. It
> > apparently worked. From what I'm seeing, it only works if
> > wpa_supplicant doesn't run as a daemon. Any ideas? Thank you very
> > much!
> Hmm.. Works for me with -wq.. Then again, I'm using Host AP driver and
> my own changes in /etc/pcmcia/wireless to start wpa_supplicant and allow
> Gentoo network scripts to start dhcpcd.
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap

More information about the Hostap mailing list