Bug in hostapd-0.4.4 (WPA-PSK an EAP-TLS no more useable in parallel)

Jouni Malinen jkmaline
Tue Aug 30 21:58:43 PDT 2005

On Wed, Aug 31, 2005 at 01:09:23AM -0300, Beat Meier wrote:

> In hostapd/wpa_supplicant 0.4.3 it worked to use wpa-psk and eap-tls 
> "parallel" in the same config file
> i.e. one client could connect with eap-tls other with wpa-psk.
> This does not anymore work with version 0.4.4. it seems that hostapd 
> does not anymore "announce"
> wpa-psk ...
> Was this a bug in 0.4.3 to use together or a bug in 0.4.4

This worked in my tests..

> Aug 31 01:04:12.827357: Scan results: 1
> Aug 31 01:04:12.827591: Selecting BSS from priority group 0
> Aug 31 01:04:12.827825: 0: 00:01:b4:02:0d:90 ssid='wireless-obera-o1' 
> wpa_ie_len=0 rsn_ie_len=30 caps=0x11
> Aug 31 01:04:12.828116:    skip - could not parse WPA/RSN IE
> Aug 31 01:04:12.828397: No suitable AP found.

Which driver are you using?

> Here diffs of config file share and wpa-psk only of hostapd

It is a bit difficult to understand what the configuration was based on
a diff. Could you please send a full example configuration that is
showing the issue?

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list