Problem with WPA-PSK and kernel 2.6.13-rc6 with ipw2200

François Valenduc fvalenduc
Thu Aug 18 05:14:30 PDT 2005

Pedro Ramalhais a ?crit :
> Fran?ois Valenduc wrote:
>>Hello everybody,
>>I wanted to take some advance and test the new 2.6.13 kernel (with RC6). I found in the mailing list archive that I had to patch the sources in order to compile the driver with software suspend. However, I don't manage to use WPA-PSK with my ipw2200 wifi card (which works fine with
>>2.6.12). You wil find in the attached file an extract of the logs generated by WPA supplicant. I use the packaged version of Debian Sid of wpa supplicant (0.4.2). It seems that the acces point is found but that association doesn't succeed. I had that I use TKIP as encryption method. I just wanted to know if this is a known bug of the driver or of wpasupplicant and we may hpe that it will be solved when the final release of the 2.6.13 will be released. 
>>Thanks in advance for your help,
>>Fran?ois Valenduc
>>ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
>>ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
>>Setting authentication timeout: 5 sec 0 usec
>>EAPOL: External notification - EAP success=0
>>EAPOL: External notification - EAP fail=0
>>EAPOL: External notification - portControl=Auto
>>Wireless event: cmd=0x8b1a len=21
>>Authentication with 00:00:00:00:00:00 timed out.
>>BSSID 00:00:00:00:00:00 blacklist count incremented to 5
>>No keys have been configured - skip key clearing
>>EAPOL: External notification - portEnabled=0
>>EAPOL: External notification - portValid=0
>>Setting scan request: 0 sec 0 usec
>>Starting AP scan (broadcast SSID)
>>Scan timeout - try to get results
>>Received 273 bytes of scan results (1 BSSes)
>>Scan results: 1
>>Selecting BSS from priority group 2
>>0: 00:11:50:4e:0a:4e ssid='cheznous' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
>>   selected
>>Trying to associate with 00:11:50:4e:0a:4e (SSID='cheznous' freq=0 MHz)
>>Cancelling scan request
>>Automatic auth_alg selection: 0x1
>>wpa_driver_ipw_set_auth_alg: auth_alg=0x1
>>ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
>>WPA: using IEEE 802.11i/D3.0
>>WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2
>>WPA: using GTK TKIP
>>WPA: using PTK TKIP
>>WPA: Own WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 0050 f2 02 01 00 00 50 f2 02
>>No keys have been configured - skip key clearing
>>wpa_driver_ipw_set_drop_unencrypted: enabled=1
>>ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
> It looks like your build of the ipw2200 doesn't suport that WPA
> interface. There can be two reasons:
> 1 -  Your kernel's .config has CONFIG_IPW* and CONFIG_IEEE80211*
> definitions which you must remove;
> and/or
> 2 - Your kernel has support for wireless extensions version 18, which
> probably disables the old WPA interface (wpa_supplicant's driver_ipw)
> and enables the kernel WPA interface (wpa_supplicant's driver_wext).
> Check [1] and if it still doesn't work, then check [2] by trying to use
> wpa_supplicant with -Dwext instead of -Dipw.
I looked for CONFIG_IPW and CONFIG_IEEE80211 but I didn't find anything
in my kernel configuration file. I also opened a and Yi Zhu
answered like you that I must use Dwext and it works with that settings.
 I would like to know how to check your 2nd point. Is it the option
"Wireless LAN drivers (non-hamradio) & Wireless Extensions" in kernel
config. Do I have to remove it if I want to use wpa_supplicant with the
-Dipw parameter ? Or is it something else ?

Thanks for your help,
Fran?ois Valenduc

More information about the Hostap mailing list