TSL - SSL error

Jouni Malinen jkmaline
Tue Apr 12 19:50:43 PDT 2005

On Tue, Apr 12, 2005 at 08:34:42PM +1000, Simon Males wrote:

> Still no go, tried also with a prism2 card and got the same result. Can 
> you point in the -d output where EAP authentication starts (where you 
> suggested the problem began). As the debug log doesn't mean all that 
> much to me and so I know what to look out for.

Please make wpa_supplicant debug log available from the case which used
includes_tls_length=1; please also use -dd to get more verbosity. EAP
starts around here:

EAPOL: txStart
EAPOL: SUPP_BE entering state IDLE
EAP: EAP entering state INITIALIZE

However, that was not the problem part here. The connection was killed
when PEAP was being initialized, i.e., after the first PEAP packet from
the client.

This is the start of PEAP (i.e., packet from AP/AS):
EAP-PEAP: Received packet(len=6) - Flags 0x21
EAP-PEAP: Start (server ver=1, own ver=1)
EAP-PEAP: Using PEAP version 1

Client replies here:

EAP: EAP entering state SEND_RESPONSE
EAP: EAP entering state IDLE
EAPOL: SUPP_BE entering state RESPONSE
EAPOL: txSuppRsp
EAPOL: SUPP_BE entering state RECEIVE

Which is followed by the driver reporting disconnection (I would guess
this happened due to authentication server not liking the PEAP packet):

Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:00:00:00:00:00

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list