wpa_supplicant fails with ndiswrapper andmadwifi driver for Atheros 802.11a/b/g card

Michael Reilly michaelr
Sun Oct 31 22:38:39 PST 2004

I have a Cisco CB21AG card which is based on the Atheros 802.11a/b/g chip 
(5212 I think it is called).  The card has a PCI id of vendor 0x168c, device 

wpa_supplicant fails when I try to use WPA-PSK.  I downloaded a trial copy 
of driverloader and it works fine.

The debug from wpa_supplicant indicates that the AP scan returns 0 bytes. 
No suitable AP is found.  I am not sure where the problem lies except that 
it fails with both ndiswrapper and the madwifi drivers pulled from the 
madwifi project's cvs last wednesday.

I am posting this to both the wpa_supplicant list and the ndiswrapper list.

What debugs should I obtain in order to solve this problem?  I ran 
wpa_supplicant with the -dd command line option and saw that the sacn 
failed.  (Sorry I lost the log I captured.  I will recreate it later and 
post it as a followup to this message.)

I am using wpa_supplicant 2.5 and ndiswrapper 0.10 (I tried ndiswrapper 0.11 
but the perl script prints out a number of error messages so went back to 
version 0.10).  The access point is a Cisco 1100.

Script I use to start the card -

# Startup the wireless card using ndiswrapper
# Cleanup in case there was a previous crash
rm -rf /var/run/wpa_supplicant
rm -f /etc/dhcpc/dhcpcd-wlan0.pid
modprobe ndiswrapper
sleep 2
ifconfig wlan0 up
wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -Dndiswrapper -B
sleep 5
/sbin/dhcpcd -d -t 300 -N wlan0


# WPA-PSK - Cisco 1100/1200 APs
	pairwise=TKIP CCMP
	group=WEP104 TKIP CCMP
#	psk="Pre-shared-key"


---- ---- ----
Michael Reilly    michaelr at cisco.com
     Cisco Systems,  California

More information about the Hostap mailing list