WDS does'nt work anymore ?

Dominique Blas ml
Thu Mar 4 19:11:56 PST 2004


I remember having tested WDS without any problem during july 2002 (hostap 2002-05 something) and everything was perfect.

Today I tried to test it again with new version of hostap (0.1.3 and 0.2.0) : nothing worked !

So I debugged :
	nothing happens in the <mac address> (*) file that lies in /proc/net/hostap/wlan0 : all the counters are zero.
	depending on the version of HostAP I can have on one side, in this file, RX counters set to something but TX counters are desesperatly set to zero while on the other side the opposite.
I tried with different versions of HostAp, different versions of kernel, different version of Sfirmware (1.4.9 and 1.7.6) as well as manually and automatically : no matter. WDS doesn't want to work anymore. 
The best behaviour I can have is only one side seems to behave correctly (wds set manually of automatically).

Strangely, when I try to send data towards Host B, a tcpdump shows that data are well transmitted onto wlan0wds0 (nothing appears with a tcpdump made on wlan0) but the wlan0wds0 interface counters stay at zero !
More strange is that when I try a AP scanning (iwpriv wlan0 hostscan 1 and iwpriv wlan0 ap_scan 20), Host B appears correctly in the list while host  A appears correctly on the list on Host B.

What is wrong with new versions ?


(*) Created when you set manually with iwpriv wlan0 wds_add or automatically .

More information about the Hostap mailing list