creating a WPA access point...

mrcool at mrcool
Wed Mar 3 13:22:10 PST 2004

Trying to create a WPA enabled access point, i get this when i try to start
hostapd (yes i know the proper commandline should be:                  
hostapd -B /etc/hostapd.conf, but its the same either way).

OfficeAP:~ # hostapd /etc/hostapd.conf
Configuration file: /etc/hostapd.conf
Opening raw packet socket for ifindex 10
Using interface wlan0ap with hwaddr 00:0d:88:50:c4:68 and ssid 'Office'
wlan0: RADIUS Authentication server
wlan0: RADIUS Accounting server
Invalid pairwise cipher (24).Could not generate WPA IE.
WPA initialization failed.
Sending RADIUS message to accounting server
RADIUS message: code=4 (Accounting-Request) identifier=0 length=74
   Attribute 40 (Acct-Status-Type) length=6
      Value: 8
   Attribute 45 (Acct-Authentic) length=6
      Value: 2
   Attribute 4 (NAS-IP-Address) length=6
   Attribute 30 (Called-Station-Id) length=30
      Value: '00-0D-88-50-C4-68:Office'
   Attribute 49 (Acct-Terminate-Cause) length=6
      Value: 11

I have tried with, and without a pass key, same error... attached is the
hostapd.conf file (that generated this error).  Kernel 2.4.22, CVS 3/3/04,
DWL650 revP flashed to 1.7.4 .

All help will be appreciated.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: hostapd.conf
Type: application/octet-stream
Size: 7259 bytes
Desc: not available
Url : 

More information about the Hostap mailing list