PATCH: send_mgmt_frame in driver.c

Jouni Malinen jkmaline
Sun Jun 20 09:28:11 PDT 2004

On Fri, Jun 18, 2004 at 09:17:38AM +0200, Gunter Burchardt wrote:

> Next patch is ready. Here is a short changelog

Thanks, applied with minor changes.

> We should rename receive.c and driver.c to hostap_receive.c and
> hostap_driver.c . I wrote wired_receive.c and wired_driver.c, but at
> this stage its no good idea to bring it into hostapd now. Perhaps a
> driver directory is a solution to seperate drivers from hostapd.

Agreed. However, I want to make the new 0.2 stable branch before these
changes. After this, we can continue doing changes in the development
branch (CVS trunk) and I'm more open to experimental code being added.
Though, I would rather not add a new directory to make the build system
more complex at this point.

> Next step is to bring successively all functions of driver.c to
> function pointers. Perhaps it is possible to make the interface to the
> driver more clear. A function pointer for example to hostapd_ioctl() 
> makes no sense.

Yes, indeed. hostapd_ioctl() and hostap_ioctl_*() functions should
disappear from the exported interface and only used within
(hostap_)driver.c. Luckily, these have quite limited use outside
driver.c, so this does not require that much changes.

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list