DWL 520 E1 (the continuing saga)

Cliff cliffo
Fri Jan 30 01:10:52 PST 2004

Well, I had an interesting morning and thought I'd share this bit of 

NOTE:  The below information worked for me once and I have since been 
unable to reproduce :(  I also was not smart enough to capture dmesg 
output before trying other things first    >:...(

I turned on the computer after letting it sit all night (still plugged 
in) and on a hunch turned off all un-needed devices in BIOS (1394, USB, 
floppy, sound, etc) and booted to MDK9.2.

I switched to console and:
modprobe hostap_pci worked fine
prism2_srec -gs wlan0 pm010102.hex loaded

Here is the interesting part.  At ths point, dmesg output did NOT show 
the usual "valid PDA not found" message after the first firmware upload. 

I was then able to:
prism2_srec -gp wlan0 pm010102.hex


prism2_srec -rs (?) blah blah

I didn't actually try to connect to an access point, but iwconfig seemed 
to be working as expected!

After rebooting I was unable to reproduce this.  I also tried unplugging 
the power cord...no luck.  I tried many variations of bios settings and 
have yet to reproduce my earlier luck.  Maybe this information can be 
useful though?


Pavel Roskin wrote:

>On Wed, 28 Jan 2004 cliffo at u.washington.edu wrote:
>>I'm using the latest version from CVS (downloaded today) and using
>>prism2_srec included in that update.  prism2_srec is failing on the
>>second firmware update for the card and I'm perplexed as to my next
>I'm fighting with this problem as well, except that I'm using a PCMCIA
>card, DWL-650 revision P.  See this thread:
>>[~]# ./utils/prism2_srec -gs wlan0 ~cliff/firmware/pm010102.hex
>><from dmesg>
>>prism2_download: dl_cmd=4 start_addr=0x003f0000 num_areas=3
>>wifi0: test Genesis mode with HCR 0x0f
>>wifi0: Original COR value: 0x0
>>Readback test succeeded, HCR 0x0f
>>prism2_hw_init: initialized in 0 ms
>>wifi0: valid PDA not found
>>wifi0: NIC: id=0x8000 v0.0.1
>>wifi0: PRI: id=0x15 v1.1.2
>>Could not get RID for component STA
>>wifi0: Failed to read STA f/w version - only Primary f/w present
>You are a bit luckier.  You don't have "init command completed too
>quickly" as I have with TI bridges, but you still have "valid PDA not
>The rest is obvious.  The second load is done so that the PDA is used.
>If it's not available, you cannot go further.
>What happens is that the primary firmware is loaded successfully.  If runs
>after that and allows to run simple commands such initialization and
>requests for version numbers.  It even returns its own version number
>correctly.  However, it fails to execute the command to open AUX port,
>which is needed to access the PDA.
>In fact, I tested the same card in two machines.  One is AthlonXP 2000
>with VIA KT133 motherboard.  The other is Pentium 800MHz with Intel 810
>chipset.  The kernel, the driver, the card and even the PCMCIA-to-PCI
>bridge are the same.  However, the card only works on the Athlon machine.
>I tried to add delays in different places but it had no effect.  Maybe the
>driver should initialize some register that is set randomly dependent on
>the bus speed.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20040130/8b028e98/attachment.htm 

More information about the Hostap mailing list