DWL 520 E1 (the continuing saga)

cliffo at u.washington.edu cliffo
Wed Jan 28 19:08:03 PST 2004

Thanks.  I haven't been using the no_primary option and loading hostap_crypt_wep has no effect.  I also tried using -gip and -gp and both of them give the same error.  Still trying...


On Wed, 28 Jan 2004, Jake Snyder wrote:

> I use a slightly different command when loading the firmware, here are 
> the steps i take.  remember that this is the new firmware which doesn't 
> require the no_primary option
> modprobe hostap_pci
> modprobe hostap_crypt_wep
> prism2_srec -gs wlan0 /etc/prism2/pm010102.hex
> prism2_srec -gip wlan0 /etc/prism2/pm10102.hex
> prism_srec -rp wlan0 /etc/prism2/rf010800.hex
> ifconfig wlan0 up
> iwconfig wlan0 mode Managed
> iwconfig wlan0 essid "essid-name"
> iwconfig wlan0 enc open
> iwconfig wlan0 key 0
> iwconfig wlan0 key 0 wepkey
> dhcpcd -t 10 -d wlan0
> i notice that your second prism2_srec uses the -gp instead of the -gip, 
> you may want to try that option.
> jake
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap

More information about the Hostap mailing list