modversions symbol problems [solved]

Michael B Allen mba2000
Sun Jan 25 23:47:37 PST 2004

Pavel Roskin said:
> On Mon, 26 Jan 2004, Michael B Allen wrote:

Thanks Pavel. I figured out what the problem was. I always forget that the
RH kernel .src.rpm has this at the top of their rpm "spec" file:

%define buildup 1
%define buildsmp 0
%define buildBOOT 0
%define buildbigmem 0
%define buildjensen 0

Except more of the above were 1. So I was building the smp, BOOT, bigmem,
etc, duh! After turning off everthing but buildup and running with the
--target i686 so everything matched the exact kernel I'm running:

# rpm -bb --target i686 SPECS/kernel-2.4.spec

I was able to build hostap_pci ok. And I didn't even let the kernel build
finish. It went on and on for about 30 minutes building modules. And I
have a 1.8GHz machine. So I just tried to build the driver in parallel and
it worked.

Installed and tested. Now I just need to see if it solved my total lockup
last night with a version of hostap_pci from ~6mo ago.


More information about the Hostap mailing list