Problem with NetGear MA311 (Prism2.5) and hostap

John Shaw jshaw
Thu Jan 22 06:40:18 PST 2004

Hash: SHA1

Sorry to bother you guys with that problem.  I went ahead and checked
out the version from CVS and it worked a lot better.  Sometimes it still
looks like my CPU usage spikes when I am using a lot of bandwidth but
the system never becomes unresponsive like it did before and the
soft_irq error messages are gone from the kernel logs.

I think I read somewhere in a how-to that says if you aren't using your
Prism 2.5 based card as an AP you probably just want to use the orinoco
driver..... that is just plain crazy, this driver works so much better
then that orinoco driver does!



John Shaw wrote:
| I recently purchased a NetGear MA311 PCI card to use with my desktop
| machine because I knew it had a Prism 2.5 chip on it and I had every
| indication they were well supported by linux.  I am running a 2.6.1
| kernel and I was using the orinoco_pci driver built into the kernel
| everything appear to work fine.  That is to say everything worked fine
| until somebody started downloading a file off my machine and my
| connection died.  I did several tests and found this always happened
| whenever I was transmitting data.
| So then I read about the hostap driver.  I build and installed the
| newest stable driver and loaded it up.  All appeared ok, card was
| detected, I got an IP from the AP.  So I go to download a file with my
| and it is actually working, but then I notice my desktop has 100% CPU
| utilization and is barely responsive.  Download finishes, thing is
| responsive again.  Repeat, same thing happens. So I did a dmesg and I
| saw a bunch of errors from soft_irq.  I have attached them to this file.
| Anyone have any idea what is wrong or how I might go about fixing it.
| It would be nice to be able to transmit and receive with my wireless PCI
| card.
| BTW, I have a Pentium III 550Mhz. with 768MB of RAM that the card is in,
| which I figure should be plenty fast enough if it weren't printing debug
| statements out of the kernel at a mile per minutes.
| Thanks,
| John Shaw
Version: GnuPG v1.2.3 (GNU/Linux)


More information about the Hostap mailing list