Kernel 2.6.2 Changes

AthlonRob AthlonRob
Thu Feb 5 19:39:32 PST 2004

On Thu, 2004-02-05 at 19:20, Jouni Malinen wrote:
> On Thu, Feb 05, 2004 at 01:00:22PM -0800, AthlonRob wrote:
> > I couldn't get the hostap drivers to compile against 2.6.2, so I just
> > grabbed CVS and tried it... AFAICT, the issue has been resolved in CVS.
> > 
> > Of course, CVS isn't quite perfect.  I now have a wifi0 that's just
> > funky and a wlan0 that works as normal and no working WEP support, but
> > some of that may be my specific card and some of it may be my
> > configuration.
> What's wrong with a "funky wifi0" interface? Does it break something in
> your setup? If you just ignore it, it shouldn't really cause any issues
> (or at least I'm not aware of any). It wouldn't be needed for
> station-only driver, but it is quite handy for handling number of
> virtual interfaces in AP/WDS setup (and thus, it is not likely to go
> away).

I suppose the funky wifi0 interface doesn't break anything... it is just
ugly, to me, to have two interfaces appear for a single card.  I
realize, however, I'm not using the HostAP drivers as they were
intended... they were written for access point stuff where this funky
wifi0 interface might be very useful.  :-)

I can deal with it.

> If you really want to get rid of the additional interface, you could use
> the CVS snapshot of the stable branch, not of the development branch. It
> should compile for Linux 2.6.2 and act more or less in the exact same
> way as Host AP v0.1.2.

Ah, cool.  Maybe I'll try and figure out CVS enough to grab that.

> I'm not aware of an WEP issues in the development version. Do you mean
> that something used to work with v0.1.2, but does not work with the CVS
> snapshot (of development branch)? Please give bit more details so that I
> can try to resolve the issues. I would need to know which card you are
> using (include NICID and PRI/STA firmware versions) and list of commands
> that you used to setup WEP.

Yes, WEP worked with 0.1.2, but doesn't seem to work with CVS snapshot. 
The card I'm using is the Airlink+ PCMCIA card:

  product info: "INTERSIL", "HFA384x/IEEE", "Version 01.02", ""
  manfid: 0x0156, 0x0002
  function: 6 (network)

... I doubt that's all the information you need.  I'll google how to get
the NICID and PRI/STA firmware versions later tonight when I have more
time to play around with this stuff... hopefully.  :-)

Ah, disregard... in the paragraph below, I was checking my logs, and saw

Feb  5 17:50:49 dell kernel: hostap_cs: index 0x01: Vcc 3.3, irq 7, io 0x0100-0x013f
Feb  5 17:50:49 dell kernel: prism2_hw_init: initialized in 106 ms
Feb  5 17:50:49 dell kernel: wifi0: NIC: id=0x8008 v1.0.1
Feb  5 17:50:49 dell kernel: wifi0: PRI: id=0x15 v0.3.0
Feb  5 17:50:49 dell kernel: wifi0: STA: id=0x1f v0.8.3

> Some very old Prism2 cards used to have odd problems with WEP. I have
> been able to get them working by enabling host-based encryption. You
> can try it by running following commands:
> iwpriv wlan0 host_encrypt 1
> iwpriv wlan0 host_decrypt 1

When I play around with it later, I'll attempt that and see what

FWIW, here's one of the WEP errors I'm getting in my logs.  I was
getting one about a missing symbol earlier saying (NULL) was
unrecognized... it seemed very odd.  It went away when I did something I
did (I really can't be sure what that something is) and now this is the
only mention of WEP...

Feb  5 17:50:49 dell kernel: wifi0: defaulting to host-based encryption as a workaround for firmware bug in Host AP mode WEP
Feb  5 17:50:49 dell kernel: wifi0: defaulting to bogus WDS frame as a workaround for firmware bug in Host AP mode WDS
Feb  5 17:50:49 dell kernel: wifi0: registered netdevice wlan0

FWIW, those lines came right after the above mentioned log entries.

To be specific about what happens to me when I have WEP enabled...

I set up WEP in /etc/pcmcia/wireless.opts in the main section claiming
my card.  The BSSID is also set there, mode Managed, etc.  I've also set
it manually with iwconfig wlan0 essid alina key blah-blah-blah-blah-blah
and experienced the same difficulties.  iwconfig reports the card
associated with my base station.  However, the 'pwr' light continues to
flash until the device has an IP (is that a new feature or a bug?) ...
or tries to obtain an IP.  If I call dhcpcd wlan0, the light goes on
solid, but I never actually receive an IP address.  If I manually set
the IP address (ifconfig wlan0 netmask the
light stays solid for a moment or two, then begins to flash again. 
Packets go out over the interface, but none are received.  My base
station has no way of counting packets, unfortunately, so I cannot be
sure if it is even getting the packets.

Killing WEP on the AP and with iwconfig (iwconfig wlan0 essid alina mode
managed key off) causes the interface to work flawlessly.

Thanks for the great work y'all have put in to HostAP... it seems a very
robust product.


More information about the Hostap mailing list