Help 802.1X support with Freeradius

Jouni Malinen jkmaline
Thu Jan 16 20:19:15 PST 2003

On Thu, Jan 16, 2003 at 11:32:23AM -0800, Selcuk OZTURK wrote:

>  When I tried to authenticate a WinXP client with Freeradius , Freeradius 
> threw a segmnentation fault and terminate. I thought framed-MTU size caused 
> this problem , so I tried to changed it with ' iwconfig  eth0 frag 1400" , 
> nothing changed at the radius side,  framed MTU was still 2304 .

Which version of FreeRADIUS and OpenSSL are you using? Why do you think
Framed-MTU would cause this problem? I do not understand how that
iwconfig command is related to this. Changing 802.11 fragmentation limit
does not have any effect on MTU.. Do you mean 'ifconfig wlan0 mtu 1400'?
hostapd sends EAPOL frames using wlan0ap interface. You should also note
that 2304 is hardcoded value for Framed-MTU in the current hostapd
implementation, so it cannot really be changed without editing source
code (ieee802_1x.c)..

> rad_recv: Access-Request packet from host, id=1, 
> length=258         User-Name = "hozturk"
>         NAS-IP-Address =
>         NAS-Port = 1
>         Called-Station-Id = "00-05-5D-D9-55-A5:test"
>         Calling-Station-Id = "00-05-5D-D9-57-59"
>         Framed-MTU = 2304

... so radiusd successfully processed some of the packets.

> rlm_eap: Request found, released from the list
> rlm_eap: EAP_TYPE - tls
> rlm_eap: processing type tls
> rlm_eap_tls:  Length Included
> undefined: before/accept initialization
> TLS_accept: before/accept initialization
> ./run-radiusd: line 8:  2388 Segmentation fault      /usr/local/sbin/radiusd 
> -X

Sounds like a bug in FreeRADIUS TLS implementation (it is marked as
experimental) or some sort of mismatch with openssl version etc. 

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list