Tx timed out! Resetting card (with OpenAP)

Robert Botha flash
Wed Jan 8 03:59:15 PST 2003

> > It seems from the Messages you pasted that you're using the builtin
> > pcmcia, and not the external package.
> > Have you tried using the external package seperately and disabling the
> > kernel drivers?
> > I've had endless hassles with the kernel pcmcia and most of them went
> > when I switched to the pcmcia-cs package.
> Thanks for the suggestion, i can give that a shot.  It's possible that the
> reason this was never done by the original OpenAP developers, with whose
> i'm starting, is that the pcmcia driver modules are too large (the boot
> for this platform is a mere 1MB of flash, and there's not much free space
> on it) in which case i'd be stuck with the kernel pcmcia.

In theory the size difference should be minimal.
After all, the kernel pcmcia comes from the same tree..it's just a much
older version.
In the kernel you're using it's version 3.1.22

> What kind of problems did you have with kernel pcmcia and hostap?  Any way
> get a better idea whether this is a pcmcia issue or a hostap issue?

Well, my issues were before I even knew about hostap :)
I use a PCMCIA-PCI bridge. I'd get alot of Resource Unavailable or IRQ 0
type errors.
And if it worked (normally by restarting the pcmcia subsystem) I'd get low
throughput and Tx Timeouts, this was using an Orinoco Silver card with
It might be different on a Prism2 card with the hostap driver.
I never tried kernel pcmcia again since I changed to pcmcia-cs.
Most of the IRQ issues went away as pcmcia-cs matured.
I think the best version I've used so far is 3.1.34
I find that 3.2.x doesn't work well for me, it keeps crashing the machine
after a day or two.


More information about the Hostap mailing list