bug in prism2srec

Michal Semler cijoml
Wed Feb 12 10:31:56 PST 2003


1 mounth ago I successfully compiled hostap with download support for 
firmware. Today I tried todays CVS and here is output of uploading 1.5.6 
which worked I mounth ago

Jouni where is problem?


srec summary for rf010506.hex
Included file name: rf010506.hex
Component: 0x001f 1.5.6 (station firmware)
Supported platforms:
  0x800a 1.0.0,  0x800b 1.0.0,  0x800c 1.0.0,  0x800d 1.0.0,  0x8012 1.0.0
  0x8013 1.0.0,  0x8014 1.0.0,  0x8016 1.0.0,  0x8017 1.0.0,  0x8018 1.0.0
  0x801a 1.0.0,  0x801b 1.0.0,  0x801c 1.0.0,  0x8021 1.0.0,  0x8022 1.0.0
  0x8023 1.0.0,  0x800a 1.0.0,  0x800e 1.0.0,  0x8015 1.0.0,  0x8019 1.0.0
  0x801d 1.0.0,  0x8024 1.0.0
Separate S3 data areas:
  addr 0x007E1800..0x007ED6DF (len 48864)
  addr 0x007F0800..0x007F1893 (len 4244)
  addr 0x007FE000..0x007FECF9 (len 3322)
Total data length: 56430 bytes
Start address 0x003f0c01

Wireless LAN card information:
  NICID: 0x8013 v1.0.0
  PRIID: 0x0015 v1.1.0
  STAID: 0x001f v1.4.9

Verifying update compatibility and combining data:
Incompatible interfaces:
  SREC: role=Actor    variant=2 range=1-1 iface=Modem-Firmware (1)
  card: role=Supplier variant=1 range=1-1 iface=Modem-Firmware (1)
Incompatible updata data.

More information about the Hostap mailing list