Unresolved Symbols

dhiraj.2.bhuyan at bt.com dhiraj.2.bhuyan
Thu Feb 6 07:16:52 PST 2003


I just faced this problem. The good news is - this has been fixed in the
CVS. Easiest solution is to get the latest tarball from CVS.


-----Original Message-----
From: Randall Hinton [mailto:bdoga at infowest.com]
Sent: 06 February 2003 04:28
To: hostap at shmoo.com
Subject: Unresolved Symbols

Hello all you Hostap junkies,

I have tried compiling the hostap drivers with many newly compiled 
kernels, 2.4.19, 2.4.20, 2.4.21-pre4, with kernel support for PCMCIA, 
with external support for PCMCIA, and with finally with PLX support, 
everything compiles fine but then I always get

depmod: *** Unresolved symbols in /lib/modules/2.4.21-pre4/net/hostap.o
depmod:         wireless_send_event
depmod: *** Unresolved symbols in /lib/modules/2.4.21-pre4/net/hostap_plx.o
depmod:         wireless_send_event

I have patched the kernel with the latest Wireless Extensions '16-4' and 
compiled wireless tools 26 in as well, they all worked fine.

My card is a Zcomax 325H card, Prism 2.5 chipset, Firmware 1.5.4

Any suggestions?

Randy Hinton

HostAP mailing list
HostAP at shmoo.com

More information about the Hostap mailing list