NetGear MA401RA can't find an open IRQ

Daniel Lyddy sprocket
Sun Feb 2 13:04:39 PST 2003


I am using a NetGear MA401RA 802.11b card, which has a manufacturer and 
model id identical to the "Phillips 802.11b WLAN PCMCIA" card in the 
/etc/pcmcia/hostap_cs.conf file.

I compiled and installed the hostap package, version 2002-10-12.

Other relevant packages:


These come from an (updated) Mandrake 9.0 distribution.

Here is what I get in /var/log/messages when I restart pcmcia services 
and insert the card:

Feb  2 12:48:12 nikita cardmgr[18553]: socket 0: Philips 802.11b WLAN PCMCIA
Feb  2 12:48:12 nikita kernel: cs: memory probe 0x0c0000-0x0fffff: 
excluding 0xc0000-0xcffff 0xe0000-0xfffff
Feb  2 12:48:12 nikita cardmgr[18553]: executing: 'modprobe hostap_cs'
Feb  2 12:48:12 nikita kernel: hostap_cs: hostap_cs.c 0.0.0 2002-10-12 
(SSH Communications Security Corp, Jouni Malinen)
Feb  2 12:48:12 nikita kernel: hostap_cs: (c) Jouni Malinen 
<jkmaline at>
Feb  2 12:48:12 nikita kernel: hostap_cs: RequestIRQ: Resource in use
Feb  2 12:48:13 nikita cardmgr[18553]: get dev info on socket 0 failed: 
Resource temporarily unavailable

Why can't this driver find an open IRQ?  Aren't the PCMCIA cards just 
supposed to use the IRQ of the controller (IRQ 11, in my case).

I have excluded IRQs 3,4,7, and 12 from PCMCIA consideration via 

Here is what I have in my /proc/interrupts:
   0:     604215          XT-PIC  timer
   1:       9308          XT-PIC  keyboard
   2:          0          XT-PIC  cascade
   5:       1709          XT-PIC  usb-uhci, ESS Maestro 2E
   8:          2          XT-PIC  rtc
  11:       4013          XT-PIC  Texas Instruments PCI1225, Texas 
Instruments PCI1225 (#2), eth0
  12:      69372          XT-PIC  PS/2 Mouse
  14:      49248          XT-PIC  ide0
  15:      34890          XT-PIC  ide1
NMI:          0
LOC:          0
ERR:         11
MIS:          0

In addition, my /proc/pci reveals that IRQ 9 is being used by some kind 
of Bridge:

   Bus  0, device   7, function  3:
     Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 3).
       IRQ 9.

This leaves IRQs 6,10, and 13 unaccounted for, plus the 11 which I 
thought all PCMCIA cards were supposed to use.

I get similar results trying this card with the orinoco_cs driver.  I 
also tried plugging in my friend's LinkSys WPC11 rev. 3 card, and it was 
also recognized and bound to the hostap_cs module, but with the same 
RequestIRQ failure.

My LinkSys wired (tulip-based) ethernet card works fine on this PCMCIA 
slot, and it uses IRQ 11 when it is installed.  However, this card also 
mysteriously appears on the PCI bus, and it uses the plain PCI tulip 
driver (not tulip_cs).

And yes, I tried loading the NetGear card separately from the LinkSys 
card, to avoid any potential conflict between the two.

Any ideas?


Daniel Lyddy			sprocket at
California Center for the Commercialization of ITS Technologies
2105 Bancroft Way, Berkeley, CA 94720-1516
tel: +1 (510) 642-5667  fax: +1 (510) 642-0910

Shannon's Law: All learning derives from suprises.

More information about the Hostap mailing list